New User Issue - X Axis not moving on One Side

Good Day everyone,… I come to you out of pure frustration… I finally have my CNC set up (almost)… Finally got to the part to connect my MAC OS and test for movement… I was able to get my Z axis and X axis to move and only ONE of the Y axis to move. My left one moves fine but my right one just grinds and grinds… I had a VERY difficult time threading the lead screw into the backlash nut, but with a little lubrication and some heavy duty rubber gloves , I was able to finally twist it all the way thru, it is SUPER tight and not able to twist even a little bit with my bare hands, but it seems as if the motor isn’t able to grab it and turn it properly since it’s so tight.

SO…I disassembled that back right motor and took the lead screw out and struggled to get it back in again and reattached everything…reconnected it to my computer and tried to test the movement again… It did the same thing… So I read the troubleshooting section and saw that I should jog the machine all the way back on the Y axis until it grinds to get it to reset. After I did that, the right motor that wasn’t moving at all now creeps ever so slightly in its movement… but NOW the left side doesn’t move at all! …Looks like the Lead screw came out of the motor and coupler, so I took THAT apart to re tighten and NOW it seems as though the lead screw will not even fit back into the coupler at ALL, like the lead screw all of a sudden is too big for the coupler, so I’m not able to push it anywhere close to the motor shaft and it barely is able to grip it for the motor to turn it. I don’t understand what is going on. How did it fit and turn previously? As for the right side, I think the lead screw is way too tight inside the backlash nut for it even to turn at all.

I am SO FRUSTRATED!! I just want to get up and running!. Do I need new lead screws? DO I need to try a new back lash nut?? I really don’t want to take this entire machine apart to take the back lash nut off! PLEASE HELP!!!

@KbyK Welcome to the group, Kawana. It’s unfortunate that your first post has to be about your frustration. I’m sure that the group will get you fixed up.

To start things off, I have a couple of questions:

WRT the tight anti-backlash nut, is the adjusting screw backed out all the way? If not, it is easy to cross thread it when turning the lead screw into the second half of the nut.

WRT the coupler, same question, I guess. Are the set screws backed off all the way? This one is a bit more curious, since you did have everything connected and working.


Hi. Thanks for the reply.

Yup the anti-backlash is backed all the way out. I’ve even taken it completely out and tried it that way. And I’ve also taken out the lock set screw completely out of the coupler as well. The left side was literally working just fine before I took it apart to investigate. Only the right side was screwed up. Now I can’t even get the lead screw in faintly close enough to the motor inside the coupler for it to grip.

Now I will try to take each lead screw out and swap them and see if that works. Or try to swap the couplers first. Ughh I don’t even know anymore. But I’m guess the lead screw on the right side is def a problem as I even had a sore wrist the next day from trying to thread it thru.

1 Like

I got it to work !!! Had to use the additional anti-backlash nut… took that off, took the lead screw off and re-threaded it through the new anti-BL. The other one was def too tight and as for the coupler i’m guessing it somehow sealed to itself after me trying to tighten the set screw so much because it wouldnt budge open enough for me to fit the other lead screw through. I had to stick a pick in the slither of opening and hammer it to pry it open more but it WORKED!! Im so happy! This community is great!

Now to figure out how to cut something!

1 Like