Newbie needs help

Hello everyone,

I’m new to CNC and am trying to get my LaserBeam from Sienci Labs working, but I can’t see anything on the wood (plywood 3.6 mm). I have watched several videos, controlled the laser via gSender, controlled the laser via LightBurn, but unfortunately. Tested various settings, again unfortunately. It appears that the LongMill is moving too quickly along the X-axis. Additionally, when I start the laser the Z axis always goes up, so it doesn’t stay at the set height. Is there anyone who can and wants to help me?

The second question concerns the standard lens. Should there be such a drop on the lens?

Material guide

not sure what you mean by drop on the lens, not at home so can’t compare pic.

Are you actually setting Z to zero? Before you run, look at Z on gsender and display should show 0.

1 Like

It looks like the lens is burned/ melted. Like there is a drop of glas on the lens.

Regarding the Z-axis, see photo. Before and after zeroing the Z axis. A value remains below zero, which the Z axis moves to after starting.



What program did you design and produce the G-code with? If you designed in LightBurn there shouldn’t be any Z moves. On the other hand if you designed in Vectric or similar software aimed at routers you need a special post processor that eliminates Z moves. JTech has a post processor for Vectric to make laser G-code.

If you don’t use Vectric, or don’t want to mess with post processors, I would recommend exporting your design as an SVG and then importing that SVG into LightBurn and let LightBurn make the G-code and control the laser. It’s probably better to use LightBurn in any case because you can set a Z drop per pass when cutting so that the laser focuses deeper into the cut on each pass.

There shouldn’t be such a ‘drop’ in the lens and I’ve seen this before. Check out this thread.

1 Like

I made the G-code in LightBurn.

I’ll read the threat.

In response to the threat, I contacted Sienci Labs via the contact form. Thanks for the support so far. I’ll wait for the response from customer service.

1 Like

If you have the design in LightBurn and use LB to control the laser it might be a problem with the coordinates and job origin. I always use the Current Position option. It is in the place where you hit start to run the laser. I never figured out how to use User Origin and Absolute Coordinates is not the way to go on a LongMill because you would have to have the stock in exactly the right place.

With Start From = Current Position you just put the laser where you want it to start from and that spot is equal to the little green square that represents the origin of the design in LB.

EDIT: Current Position is here in the LB docs

1 Like

I design in LightBurn and load the design into gSender. I will test what you say regarding the current position as soon as I have a properly working lens.

Just to make sure I was clear, in my last post I was talking about having the design is LB and running it from LB and not using gSender. I love gSender but for my laser work I just use LB.

Hope you get back up and running soon.

1 Like

Thank you _Michael. Another short question: You have your S-value max at 255 or 1000?

@GeorgeV In addition to the help you are getting from others, I would add that, if you are using LB to control the laser, make sure to set $30 and $32 in the console of LB. $30 must be the same value as your S-max.

Looking at your pic, it seems to me that you have a lens issue. You should open a support ticket and include that pic.

2 Likes

Thank you. I’ve just done that.

I have my S-max at 1000 because it makes it easy to see the correct power in the G-code you just have to move the decimal one place to the left e.g 460 = 46% power.

I’ll also mention what Grant said $32=1 is important when using the laser.

$30 = S-max in LB
$31 = 0
$32 = 1

Those are the ones that are important for the laser.

EDIT: Just in case you didn’t know you can check the settings by entering $$ in the console and it will show the settings and entering $number=value will set a setting from the console e.g $32=1

1 Like

@GeorgeV I’d echo @_Michael

I believe the grey numbers under the large blue 0.00 after zeroing are relative to your machine’s home position. If your Gcode is using them that could explain it.

could you post some of the start of your gcode and/or a pic of the lightburn screen with origin displaying?

Lightburn does allow movement of Z, but not by default. check Setting Z axis position - LightBurn Software Questions - LightBurn Software Forum and set according to what you are doing.

2 Likes

That’s correct the the small numbers are machine coordinates. Machine coordinates are (0, 0, 0) wherever the machine is powered on without homing. With homing (0, 0, 0) is where the machine homed to.

1 Like
; LightBurn 1.4.03
; GRBL device profile, current position
; Bounds: X0 Y0 to X156 Y263
G00 G17 G40 G21 G54
G91
M4
; Scan @ 10.4 mm/sec, 100% power
M8
G0 X90.008Y9.604
G0 Z3.6
; Layer C00

I see now in de code what the isssue could be. :wink: “G0 Z3.6” Is it because of the material setting on 3.6 mm. (I’m sorry it’s in Dutch)

I think your right. I don’t remember ever setting Material.
If you save it with 0 you should see it in the gcode if it doesn’t set it.

Please let us know if that fixed your issue

@GeorgeV I’m not any where near an expert in LB, so I was confused by the “material” setting in your layers window as I don’t have that setting in my layers window. Doing some research, I found that setting is triggered by the “enable Z axis” in Device Settings. I have that turned off; you have it turned on. FWIW, as a test, you may want to turn that off in Device Settings and turn on “relative Z moves only”. That has worked well for me.

Edit: I have deleted a comment that I made in reference to “air assist”. I believe that it did more to confuse members than help. I apologize for any confusion that I caused.

@gwilki @_Michael @Shipwreck I will return to this subject / topic when I receive the new lens.

@gwilki @_Michael @Shipwreck
I received my new lens last friday and tested the laserbeam. Everything is working like it should. The issue was the lens.
Thanks for helping me out.

3 Likes