Odd sound after atempting to square (video included)

MK1 30x30
New Gsender release (1.4.2?)

I had to unmount my longmill to fix my table and now I’m having issues remounting it and getting it square. It was working and sounding fine before but after remounting, it sounded like a rock tumbler when jogging towards me on the Y-axis and the lead screw seemed to wobble a lot. Jogging it back everything was still present but not as bad.

I tried adjusting the V-wheels and backlash nuts with some success but it still did not sound terrific. I was going to stop for the day but decided to run the calibration tool, XY squaring.

It said it was off by 0.6mm
It also said the epomms could be updated

I clicked update and now it sounds horrible. If the vid is not working let me know and I’ll try to fix it.

It had a nice steady low-pitch tone, not this choppy high-pitch tone Is this normal sounding? Can I get the prior settings back or should I get them back?

@Swinly For me, it’s always hard to tell from videos if anything is off. I’m sure that others will contribute, but to me, nothing sounds out of whack. I’m wondering if the change in pitch from your previous eeprom load is a change in speed. What is the max speed now when you are jogging?

I assume that you mean that you are running gSender 1.4.1. Since it would be back to the future if it was 1.4.2. :grinning:

1 Like

Watching the video again it doesn’t sound as bad as I first thought. Maybe since I wasn’t sure what updating the eeprom would do, the change in pitch took me by surprise. I probably should have looked that up before clicking update.

Since the eeprom update came as an option while using the XY squaring tool; does it have anything to do with it being out of square?

@Swinly I don’t believe that it should. It would be more likely that it is out of square by that small amount owing to your unmounting and mounting it. It’s not hard to be out .6mm.

I diffidently know it is out of square because of me. Every straight edge and square is ‘broken’ when I use them. I also have a bad habit of pushing buttons when I’m not supposed to.

I’m more curious about the reason the XY squaring tool in gsender suggested the update or change to the eeproms. Was it due to me possibly being sloppy with my measurements when using the tool in gsender?

@Swinly The short answer is “I don’t know”. The longer answer is: let me look at that later this morning. The only time that I remember gS telling me to update the eeprom was if the calibration was out. (An input 50cm move was not actually 50cm, for example.) When squaring, I only remember it telling me to move one of the Y gantries back by x amount.

@Swinly I now see what you are talking about, Lonnie. Question: When squaring, when you jogged the distances in X and Y that you set in gS, did the LM move those distances? Example: you set it to jog 100mm in X and 100mm in Y. When you measured the actual jog distances, were they 100mm?

@gwilki My measurements were slightly off. I don’t remember what they were but something like 99.85, 100.25, 99.785mm Those numbers are pure guessing and could be plus/minus some.
I know that I was not careful when measuring the distance traveled and entering the values.

When I entered the values I thought it would only tell me, "move left Y rail forward 0.6mm or right Y rail back 0.6mm) Which it did but there was also the message about my eeprom could be updated.

Since this was a new build, my first time using it, the squaring tool, and the use of the word update, I thought it may have been a normal update. It wasn’t until after I clicked the update button that I thought it may be a result of not carefully measuring while using the squaring tool

@Swinly If you are concerned that you may have changed some settings based on inaccurate measurements, you can easily go back to defaults. In gSender, open the firmware window. Choose flash grbl and when that is done, choose load defaults. You will be back to the way your eeprom was when you first started out. If you are worried about undoing some changes you have made, export your current settings first. That way, you can always import them back if you don’t like the default.

1 Like

Okay I was about to flash grbl but a warning came up saying I could damage my machine from improper flashing. Now I’m nervous to click it. lol

In the firmware window, 3 settings have a reset to default icons. The X and Y travel resolutions which now have values of 199mm and 198mm, the default of both is 200mm. The third setting is the max X travel from homing switch set at 812mm. the default is 304mm. But I don’t have homing switch

Should I still flash it or click the reset to defaults on those two settings, X and Y travel resolutions?

@Swinly I think you need to do what you are comfortable with. You can set those values back to their defaults. If you don’t have switches, that setting will be irrelevant.

Since this exercise started because you were concerned about the sounds your LM is making, if you are no longer concerned about that, you don’t necessarily need to do anything. That said, the changes in X and Y resolutions were likely changed as a result of your measurements being off a bit. So, putting them back to default can’t hurt.

In the end, I’ll repeat that I am not tech support for Sienci. I’m simply another LM user, like you, Lonnie. Tech support should be the ultimate advisor on this, if you are concerned.

Sorry, I didn’t mean to treat you as tech support. I was trying to learn more from other users’ experience

@Swinly No apology necessary, Lonnie. I was simply concerned that you believed that I know more about all this than I do. :grinning: Like other members here, I’ll do what I can to help. As I know you do. It’s simply that I have limitations that tech support does not have.

1 Like