Official 0.7.1 Release Thread: Bug fixes and more reliability!

Thanks for the work and look forward to trying this build. My household is trying to get over a horrific battle with Covid19. I’m not sure when I’ll have my strength or lungs back, but hope to get back in the shop soon.

@Swinly I’ll think very good thoughts, Swinly. I hope that you get well very soon. :mask:


Not sure where to report bugs - after setting a button for jogging the z axis on my joystick, pressing that button causes the z to move continuously and it won’t stop without pressing the stop button on the LongMill controller.
gSender 0.7.1


@Jimbo Jim: Does it do the same thing regardless of the jog mode selected - precise, normal, rapid? Can you map a different button on your joystick to jog Z and see if the problem persists, please?

Hi - the jogging is starting to be rather unpredictable. The most annoying aspect of this is when the router travels farther than I asked - I had several incidents today where a 1mm Z jog suddenly moved 10mm - which is nearly catastrophic when traveling down…
Other aspects seem to be pretty reliable.

1 Like

I’m back in the shop and downloaded the new build. (Thanks for the good thoughts) I noticed it doesn’t run when you when you click finish while having the box checked to run program. Minor but thought I’d mention it.

I’ve also noticed some jogging issues too. It seems to jog a bit longer than I intend for it to. I believe it has only been on the Z axis.

I am still a little foggy from covid so this all could be me too.

I tested this further: The problem exists on all 3 speeds. I also reassigned buttons to be sure the issue wasn’t associated with particular buttons. Regardless of which button or speed, jogging the z with the joystick causes continuous movement which can only be stopped with the “oops” or stop button on the control module.

1 Like

Seems to be specific to joystick functionality then? I hope we haven’t broken the jogging through regular means (button clicking & keyboard shortcuts)

Actually, I’ve broken 2 2mm end mills in the last 2 days when the “precise” Z- jog suddenly moved roughly 10mm down hard into the stock. I consider fixing this thoroughly and quickly a very high priority. Not being able to rely on the jogging is a killer.
I’ve been doing the jogging by clicking directly on the UI. I have an application called ‘touch portal’ that can send key stroke sequences to gSender, but it gets less reliable with each revision to gSender. I’ve temporarily stopped using it, waiting for some stability to return.
I thought that perhaps the mouse was at fault, and switched from a wireless mouse to an older wired mouse. That had no effect - I broke 1 end mill with each one.

Frank, we haven’t been able to replicate this issue on our end. Me and the team just brainstormed a bit on this but if you have a video of the issue occurring (obviously I’d recommend not having a bit in the router while you’re replicating it) with the Console tab being visible as well, then that would go a long way toward us understanding what could be happening :+1:

On a separate note, I’m curious what the application of the touch portal is fulfilling for you

I’ll see about trying to replicate it. I can’t have the console visible at the same time as the router as they’re about 5 feet apart. I’ll focus the camera on the console while I jog with no end mill in place; however, I don’t know how long it might take to catch something.
The touch portal “host” running on the controlling computer communicates with an iPad mini running a second copy (via wifi), and I have custom pages set up with buttons for the operations I want to have gSender carry out - jog right, go to precise modem,etc. I can hold the iPad directly in front of the router while I jog it without switching attention between the computer and the LongMill. It’s analogous to people using a console controller, only I have more flexibility.

I replicated the problem, and have video of the console. There’s a comment at the front, and the actual problem is at the end. It’s about 1.5 minutes:

The final jog movement goes from Z-0.1 to z-1000.
Something about pressing the mouse button a little harder than usual seems to be the culprit. I have to have a VERY light touch with the mouse.

1 Like

Thanks for the video.

The behaviour of the button is to send either a single jog command or a continuous jog command based on how long the button is held down. Right now the threshold is 250ms - if you hold it down longer than that, it will assume you want to continuous jog and send a larger movement.

For the next build we’re going to look at tweaking the values specifically for the the Z axis to make it a little less touchy - we’ll look at doubling the activation time for continuous jog to 500ms and also change the movement speed on Z to be a fraction of what’s set for more precise Z movement. 10mm movement overshoot is probably not super noticeable when moving in the X or Y axis on continuous jog, but on Z where you’ll hit the workpiece it becomes a problem - we’ll see if these new values help in that regard.



So it’s meant to overshoot on the X and Y when doing a continuous jog? I got sick with Covid for a little over a month and didn’t do any work on the longmill. When I got back in the shop I thought things felt different with the jogging. I had no idea if it was me or if my brain was still on sick time.

It’s not meant to overshoot - there’s just a delay when the movement is stopped via a jog cancel command to where the head decelerates to a stop - the movement finishing isn’t instant nor can it be. Nothing has changed wrt how jogging works.


oh okay, thanks

so it was my brain

Since 0.7.1 update, mine also extends the jog past my intended jogging stop. When I’m holding any of the directional jog arrows and release the mouse button, the router continues for quite a distance after I release the mouse button. I’ve crashed the z-axis several times already.

It didn’t act like this with prior updates. Previously, when I released the mouse button, the movement stopped instantly.



1 Like

I downgraded back to 0.6.8 to stop the issue of all three axes continuing movement beyond my release of the mouse button when using the arrow buttons on the screen to continuous manual jog.

With 0.6.8 and prior, there was no overshoot…when I release the mouse button, the movement stops immediately. All three axes.

With 0.7.1, after I release the mouse button, the travel continues for a second or so. You have to guess at where the router will actually stop.

Is there a place in the settings to control this overshoot?


1 Like

4 posts were merged into an existing topic: Official 0.7.2 Release Thread: Improvements for endstops, axis setting, and more