Official 0.7.2 Release Thread: Improvements for endstops, axis setting, and more

Happy Friday everyone! What a wonderfully busy time it was these past two weeks on gSender development, yet I’m very happy to have come out with quite some grand results. Once again, these developments are always in thanks to many of you who submit feedback, whether it’s a bug that’s giving you grief or a suggestion for improvement.

There was some great bug fixing this round but also some great new features!

What’s new / fixed?

  • Manual value entry for X, Y, and Z locations by clicking on the location indicator
  • Re-designed job progress indicator that better shows operating time and path of current file
  • Now able to use variables in start/stop g-code blocks and tool changing
  • Ability to enable or disable start/stop g-code blocks without clearing code
  • Updates to included firmware image and Longmill default EEPROM settings in firmware tool to support endstops
  • Endstop buttons now appear automatically if homing is enabled, and the home button is available on machine connect
  • Rapid position buttons now available and updated to use new firmware settings
  • Individual X and Y axis Go To buttons now use safe height if set in preferences, GotoXYZ0 now changed to GotoXY0, and safe height now complies to endstop-enabled machines and doesn’t descend after movement
  • Better support of physical hold/unhold buttons on Longboard controller
  • Tweaks to Z jogging to reduce runaway issues
  • Fixed hard limit alarms to allow easier resuming of workflow
  • Fixed bug with Z movement at end of surfacing program in imperial units
  • Joystick jogging should now send jog cancel at direction control release
  • Fixed last line run to reset on job completion

Topics I’ve noticed feedback on that we’ll be looking to address soon:

  • Headless Pi operation
  • More guidance for first-time users

How are y’all finding these? Let’s discuss.

Also, new updates have come to the gSender doc with more still on the way this coming week to go and give it a read and watch out for more:

Happy Friday y’all, enjoy your weekends!

2 Likes

Do we need to uninstall or delete anything before installing the new build?

It shouldn’t be necessary. It should be able to install right over-top of the previous install.

I have heard reports from other members who occasionally see issues with correct overwriting, but have yet to confirm that as a necessary step

1 Like

A post was merged into an existing topic: gSenter not updating properly

@Heyward43 What I find most interesting about your experience, H, is the statement that you noticed the download when opening .7.1. Way back, I used to get an update notification. I have not gotten one now if a few releases. I just go to github when Chris announces a new release, download it from there and install it.

Just out of curiosity, where does the update notification appear? It could be hiding from me in plain sight.

@gwilki - Hi Grant, I sometimes get it as soon as I open gSender. Other times it will show up after I connect and start doing things. Either time I have had to run it twice to get it to update. This started back on 0.6.9 or 0.7.0 I believe. The download and install box on my screen is in the lower left corner just below the visualizer and I get the little bouncing arrow in the upper left corner. The first time it happened I was obviously confused so ended up, like you, going to GitHub and downloading from there. If I do it through GitHub I uninstall the previous one before installing the new one. And now that we can export/import the setup I will be doing that too to save my keypad setup.

1 Like

@DLare Dean: That is one of the issues that Sienci addressed in .7.2. Could you try it and report back?

Just a few quick questions, if you don’t mind. Are you using a wireless or wired mouse? If wired, is it plugged into the PC or into a hub? If a hub, is it powered?

These questions are not meant to be critical of your set up. If .7.2 does not solve your problem, I’m simply trying to see if any hardware configurations could be contributing to the problem.

Grant,
Thanks for trying to help :slight_smile:
I just tried 0.7.2 and it acts the same.
Mouse is USB directly to the PC.
At a jog travel speed of 100 in/min, in X or Y it travels an additional 1" (approx) after I release the mouse button. Z axis is slightly less.

In version 0.6.8, it stops as soon as I release the button (no overtravel).

Weird, but frustrating.

Dean

1 Like

I thought it felt different. I too just went back to 6.8, the jogging is much better now. I also tried 7.2 and you still had to try and anticipate where it was going to stop after release. It’s frustrating cause I really like gSender. Here’s to 7.3…?..but 6.8 for now. lol

I’m on win64

@DLare @Swinly It’s odd, because I cannot duplicate the problem. I tried jogging speeds from very slow to 5000 mm/min and each time I remove my finger from the mouse button, the Mill stops - no lag at all. I’m sure that techs at Sienci will he looking into this.

I moved your posts to the .0.7.2 topic so that the Sienci techs will be sure to see them in the context of that release.

2 Likes

Hey folks, thanks as always for reporting issues you see!

  1. Go to XYZ0 is now Go to XY0 - so that button no longer also going to Z 0 was an intentional change, not a bug. Feedback and usage metrics we’ve received indicates that going to just XY was the most common use-case for workspace coordinates and we’ve made this change to support this. You are still able to go to XYZ zero by clicking the “Go XY0” button followed by clicking the “Goto Z” button. This is something we’ll continue to evaluate based on feedback received but for now we want to make the more common use-case “easier” with one button click (Go XY 0) instead of two (Goto X, GotoY).

  2. We’ve identified an issue where the jog cancel command was being sent delayed from the mouse up event when you release the button - this issue was introduced with other changes we’ve made to prevent the jog freezing we had a few builds ago. This should be fixed in the next build.

The technical explanation is that the jog cancel command is debounced to sync with the 250ms timeout on button hold between normal jog and continuous jog , but the default debounce behaviour was to send the trailing event after 250ms instead of the leading one as soon as the button is released. This is why it “overshoots” - it travels another 1/4 second before being cancelled and then decelerates to a stop.

  1. We’ll look at updater issues but this is inconsistent across users so might be tough to track down - it works fine for some (and me personally) but has come up more than once. I have a feeling it may be related to Windows Defender which will hopefully be rectified soon as we’re going to start digitally signing our releases.

Cheers,
Kevin

2 Likes

Thanks for the explanations Kevin :slight_smile:

Opened gSender and immediately clicked “Download and Install”. changed to “downloading” . Waited…an Hour. This has happened to me before and (thought it was my laptop being slow or my internet being slow since I am using DSL and always have issues) eventually started the downloading and installation process. Once all that was done I get to the “Finish” Screen and select Open Gsender and Finish.gSender never Opens! I wait several minutes (again thinking it is my computer being slow) and nothing so I click the shortcut Icon and open gSender. Only to find the previous version (7.1) running. Rebooted and reinstalled three times with no luck.

@Dana Dana: I have no clue why that is happening. I’m sure that the Sienci techs are listening. In the meantime, if you want to download and run .7.2, you can go to the github and get it there. Here is the link:

You can choose your OS and download the appropriate file.

1 Like

Thank you Grant! I will do that.

@Dana It is weird, Dana. I don’t even get the notification that there is an update when I open gSender. I did early on, but not for the last few releases. For all I know, it has something to do with the settings on my PC. As long as I can get the update, I don’t see it as major deal.

Have fun.

Yeah I feel the same way. Since I have been using the end stops my continuous jogging feature doesn’t work. I wore out a mouse already! lol Took me a bit to understand the contraints as well. I disabled them on my last project so I could get the full carve area when I surfaced the waste board. I don’t pretend to be the sharpest tack in the box but, learning the value of all that gSender has to offer has been a challenge for me. I am sure I will get it eventually. Thank you for your help!

I really enjoyed this update. Life has been so busy I only get to walk past my longmill. #notLivingRight. Can’t wait to try the new version of gSender. I’m really interested in the endstop switches as well.

1 Like

Hey everyone, the next version is now out and has an associated release thread! Check it out, let me know what works and what doesn’t work, and we’ll continue forward from there :smiley:

@Ratmeat, end stops are waiting to be delivered and then we’ll make them available
@Dana, I was pretty sure that continuous jogging with end stops had been addressed in a more recent build, can you check that this is still an issue with you? Also, do you feel we could be clearer on what gSender offers?
@DLare @Heyward43 @Swinly I think all your comments in this thread are now addressed in the new version. Let me know :+1:

1 Like