Pocket clearing - Fail x 2!

I thought I had learned but my second attempt was somehow worse…
I just got my longmill running and I just programmed a couple pocket cuts today to test some different settings.
I thought I narrowed in on my issue and adapted my clearance height, and retract heights. Apparently this wasn’t the problem…? On my second test my router retracted to the height that looked like my clearance height, and then quickly dropped and blasted through the material much faster than I could press my emergency stop.

I’m sure I’m missing something really simple here? Any suggestions?

I’m using Fusion360 and both pockets were cut with the 2D pocket operation.

Do you have limit switches, especially on your Z axis?

Idea 1)

I had similar “seemingly random” issues like this in the past and upon close inspection discovered it was usually that I got to the bottom of the physical Z down travel even though I hadn’t reached the target depth in the file.

In a situation like this, with the machine on and cutting, you likely won’t hear it bottom out and grind for the few extra MM of travel. Especially if you have your hearing protection on.

You could check for this by halting the job, powering off the router (!), and then looking at the read out on UGS to see where it thinks the current machine and workspace Z heights. Take a screen cap on your phone so you have both.

Then take a small ruler and measure where the end of the bit is relative to the table top and workpiece top. If you can’t align the numbers (sorry the logic escapes me but will likely be obvious to you in context) then your Z is out and you bottomed out.

If it is weird, the machine thinks it is at a certain depth in the gcode but it is physically at a different depth. This can cause all kinds of strange things to happen (and can happen if you hit the top of your Z travel on the upside too).

Looking at your picture, that looks like 3/4" baltic birch or maybe 1". I don’t know hw deep your pocket is but it looks like it blew through the side at about 15mm or 16mm. So if you had a nunber like that show up in your Z offset that is likely it.

Another sanity check - if you measure the depth of your pocket with your caliper, is it correct compared to your drawing or is it deeper or shallower? If it is materially off, your Z is probably out.

It may not be this, but something to be aware of. Limit switches are a must, in my opinion. Z up is easy, Z down was trickier to sort out. But having the job pause and throw an alarm if you over run your Z axis will save a lot of time.

Idea 2)

Not sure what CAM software you used, but I did have this particular thing happen early on with Fusion 360. I -think- the answer was to always turn on “stock contours” in the setup menu for the toolpath. That tells the toolpath to keep it’s travel at cutting height constrained to the workpiece and otherwise retract. Without doing this (and my memory is a bit fuzzy) but I believe I had it treat the “waste” stock as far game for transiting across - sometimes at a great distance, before starting or ending a job. Haven’t had it happen in months but I always check stock contours and double check the simulations (although this may not show up in the simulation and still happen, IIRC).

That being said, I didn’t have limit sensors then and I think I sometimes had two or more compounded problems so take this one with a grain of salt.


I had similar issues in the past, I was using UGS, once I switched to CNCjs I (touch wood) haven’t had any more issues.

1 Like

Ok great I’ll try that software with the same gcode and see what happens!

Awesome thanks for the tips.

I haven’t tested out my Z-axis accuracy so I’ll definitely check that.

My stock was 1-1/4" Maple. My first pocket depth was cut to 5/8", the second 7/8" with no similarity in the heights from which the cutter retracted and blew through my material. 1st pocket retracted 7mm from the bottom, and the second was 5mm from the bottom. Not seeing a pattern yet.

Ill try your suggestions and see what happens!

Were both pockets the same depth in your drawing and did they cut to the same depth? If they were the same in the drawing and cut to different depths, that is a sure sign that the Z has been thrown off.

I had two more thoughts:

  1. Check your heights tab for clearance height and all others in your CAM and make sure it is identical if the pockets are in different tool paths. I’ve had an issue where I sometimes made a change on one toolpath that was desired but forgot to repeat it on another tool path.

  2. I remembered when I was filming a few brief videos about my sensors just now that I had some issues with the gear on the top of the Z not being tight in the belt and getting slippage there which lead to the machine thinking it was in one spot but being in a different one or getting random height changes. Double check that it is all tight.

Let us know what it turns out to be.


I made some videos for you to show the sensors too: Inductive Sensors for Homing and Limit Detection

I think I have two issues going on…
I don’t think I had given enough information about my stock piece to CAM, and it seems like the bottom was potentially being registered as the top? I’m still a bit unclear on this.

My other finding was that my Z lead screw bearing had come loose. I had played around with the machine a bit after my pocket cuts, so I’m not sure if this was a problem at the time of those cuts. However, I had to disassemble and reassembly the Z pulley system and re-set the bearings and lead screws. Unfortunately I just did some super simple relief cuts to mark out the overall machine cutting area, and the set screw that holds the nut/lead screw has come loose again. Am I cutting too low and stressing the system? I can’t figure this out.

I may have to make a separate thread for this Z lead screw issue, I’m not coming across this problem in other posts.


On another note: Thanks so much for the videos! That’s definitely my next mission.

I had the exact same issue at the start and it took me a while to find it. The belt/pulley setup was loosing steps - sometimes - so it was sporadic and strange.

My first week or two seemed like a lot of chasing “loose” things and tightening them. I think it is very hard to convey the right amount of tension to be used on various connections and some of us maybe errored on the side of too lose. I went back through the Maintenance section of the wiki/setup not long after that and patiently did everything, as well as rechecking every bolt and wheel and things seemed to settle.


On my MillOne this almost always is an issue with a loose connector on the Z access. I think what happens is the connector is loose, you do a lot of work in the pocket, getting deeper and deeper then the cut is over and the cnc pulls router up the positive Z access putting stress on the already loose coupling (or whatever it is on the longmill) and then it drops. So I check my z connector after every job ends.

1 Like

You should also consider where your router is in the spindle mount.

Is the blue top near the mount (so it is sitting “low”) or is it sitting mid body? Mid body or a higher position will give the least chance of deflection at the bit but a higher chance of running out of travel depending on how much spoilboard height you have, how long your bits are and how thick your pockets are. Remember the router with bit is a lever held in a single plane. It’s held really tightly but with really long router + bit cuts in deep pockets, it can affect things, especially if anything is loose.

The problem with raising it up is you decrease your available Z-travel so are more likely to bottom out without realizing it, unless you double check all your math. This is why I am so happy I finally figured out how to do a Z down limit sensor. I can still do it, but I’ll know immediately and the job will halt.


Yeah I will have to be more mindful of this! I also just tried running a simple surfacing file and I am getting at least 3 different depths when I only programmed 1. I think it’s time to try different software.

I have tried tweaking everything else so new software it is. If that doesn’t work I guess it’s just me

@equal_lateral If you want to post the gcode for the surfacing file, it should be easy enough to see if that is your problem.

With Fusion 360, the default at the end of the job is to return to the Machine Zero Point. The LongMill has no homing switches, so whatever position it is in when it is powered on becomes the Machine Zero Point.

When you are post processing your CAM, change the Safe Retracts to Clearance Height instead of G28. This should have the Z-axis move up to the Clearance Height straight up at the end of the job instead of returning to the Machine Zero Point.

1 Like

This seems to be helping to resolve some of my errors, thanks!

Ok so i was suffering from this type of thing and today I seemed to have gotten past it. I use cncjs and 360.
So in 360.

Bottom height is generally “selection” and I select the lowest point I am milling.
Top height is generally either the stock height if that the highest thing, or the model height, or a selection
All the other heights are offsets above the previous lower one.

On the Post make sure “Safe Retracts” is set to Clearance Height

On cncjs (or whatever you are using)
I move all my XYZ to where i want the origin of the job to be. Z is typically a sheet of paper above the stock/model height. Zero everything.
Close USB connection. Open USB connection
Zero out all the values again
Close USB connection. Open USB connection
Now cncjs shows all values at 0. Load fusion post code and mill.

1 Like