Post-processor selection for Aspire

I lucked into an Aspire license. I’m still figuring out the software, but I’ve figured one thing out so far. I setup my material with inches, and then when exporting the toolpath you have to select a post-processor, and it comes with … hundreds?.. of options. Long mill isn’t among them. So after a few bad guesses I went with the “Shapeoko (inch)” and that worked pretty well. The measurements came out as dead-on as I can measure with a simple tape measure. Thought I would share for the benefit of anyone else that runs into this situation.

Happy carving!

Aspire should be the same as VCarve Pro and Desktop. Use GRBL Inch. Shapeoko might be similar but don’t know for sure. I believe most of us with Vectric products use the GRBL settings. I have Desktop and exclusively use GRBL Inch.

3 Likes

I, too, use grbl inch with VCarvePro. Aspire uses the same one.

2 Likes

I use gcode, inch as well but need to edit out the pause/tool change code at the start. Has anyone figured out a way to avoid this? Using Aspire 4.0

@coco - Search this forum for “Permanent Fix” and you will find instructions on how to remove offending lines or setting up permanent overrides in UGS. Good luck and have fun.

@coco I use grbl inch with both VCarvePro and Aspire 9.x and those codes are not in my files. It may be worth it, Stephen, to change from gcode inch to see if the codes are still there in your version of Aspire.

MY gcode created by Aspire 4.0 starts like this:

T1M6
G17
G0Z0.8000
G0X0.0000Y0.0000S12000M3
G0X5.7413Y-0.0313Z0.2000
G1Z-0.1250F30.0
G1X5.8351F100.0
X5.8396Y-0.0309
X5.8442Y-0.0299
X5.8488Y-0.0280
X5.8532Y-0.0254
X5.8572Y-0.0221
X5.8605Y-0.0182
etc.

Code is in Metric as gcode well.
Tool change T1M6 needs to be deleted or the unit just stops.

@coco Is this using grbl inch as your post? If not, try that and see what the code looks like.

Yes, tool change T1M6 is in both metric and inch gcode files.

@coco Stephen: I wasn’t clear, sorry. You’ve said that you are using gcode inch as your post. I suggest that you change to use grbl inch. I used grbl inch and do not get those codes. I am using a newer version of Aspire and VCarve though. They offer grbl inch as a post. I don’t know if your version does.

Version 4 does not so I have to change it manually in UGS

@coco Stephen. I don’t know how much of a pain this is for you, but I have the posts from grbl in can mm from vectric that I believe you can add to your version of Aspire. I cannot attach the files here, but if you want to try them, send me a private message with your email address and I will send them to you.You could also write Vectric and they will supply them.

I’m not sure how to add it but willing to try if you send the file.

@coco Stephen: I can’t attach the files to a thread posting. If you would like to try them, send me a personal message with your email address. I’ll reply, attaching the files.