Problem with inductive sensor setup

I upgraded my mainboard and X, Y, and Z axis’ all move correctly when jogging - cool!

Then added the inductive limit switch kit, and machine trys to zero X and Y in wrong direction - away from the front left corner. Also, I cannot stop this wrong zero motion with a reset, it keeps restarting and will jam the X gantry against the back right corner. The limit switches work; as I tested the with a metal wrench handle.

The setup instructions call out 1’s 0’s in the commands but the Gsender setup software uses Enable and Disable terminology.

I am getting ready to completely reset the longbord in frustration.

This is a version 1.4 board, what are the actual “Enable”, “Disable” settings for the sensors a motion?

Other issue I had was with the inductive sensor kit sensor brackets. Two of the thermally inserted screw inserts popped out; one on the X bracket and one on Z probe bracke. And no, I did not over tighten them. I have been reduced to Hot Glue to insure the sensor mounts do not vibrate loose. I also found that the Z sensor barely catches the top of the Z axis plate for sensing. This bracket needs to move the sensor closer to the edge of the top plate to insure if it vibrates loose, it will continue to trip on proximity to the top edge of theZ axis plate.

Well, on to the reset…

@Scottinharwood , There is a video included in the online instructions for installing the sensors. It will tell you how to change the EEPROM. I followed it and my setup works so I think they are correct. One setting is different that what is in the text instructions so I’m assuming they are wrong.

I used Gsender to set up the switches and the default settings were correct, I did not do anything in the console. Gsender also has a firmware tab that makes it easy to adjust all those settings for limits.

Note that homing is all on the microcontroller from what I understand, the computer can’t halt the machine, you have to reset the controller.


1 Like

I love being able to Home my machine now, but…
Every so often I get a hard limit warning error when it’s nowhere near the limits.
Also, I can’t turn on the Soft Limits because it won’t allow for normal jogging.
I’ve worked with Chris Thorogood and we still haven’t figured it out.