Question, what am i missing

ok people, complete newbie here. using carveco maker. trying to setup a surfaceing pass on my spoil board. draw the project lay out the work perimeters and name and save the file. go to create tool paths and it throws a error message, “no vectors selected with in image”. what am i missing?

1 Like

@lonnie - You simply need to select the outline of the cut area. It should turn a different color once selected. Easy mistake. I still make them.


ok thought i went through that but, guess i fumbled it…ill go try again. and give ya a update in a few… thanks

nope tried that but not getting anywhere with it. give me a day or to… if anything i am patient and persistant .lol. appreciate all the help your throwing my way.

1 Like

@lonnie - Is it possible you have an open vector? Just a thought. Did you draw a simple box for your cut area? Are you using a pocket cut or something else?

Newb here too and I’m also using carveco maker. The only time I ever get that error message is when I don’t have any vectors at all or none selected. Have you actually created the vectors and not just a bitmap image of it? If you do have the vectors try selecting them with the mouse by clicking and dragging from right to left over them to make sure you selected all of it

no to the open vector thing. and yep have created vectors and selected them. carveco telling me i have intersecting vectors and can not generate tool paths?

@lonnie If you have intersecting vectors, you must have more than one rectangle. I would suggest beginning with a new project. Draw a rectangle to the size that you want, select it and try to create your toolpath. It’s a very simple project, so this should work. If you want to play, select the vector and delete it. Something should remain, that something being the vector that is intersecting with the one that you deleted.

lol, grant if only my life was so simple. tried the delete and replace the specific vectors and got no where, so yeah, quickly getting to the point where G binning this drawing and starting fresh. But damn i was so impressed when i got the first two tool paths to show up and save?

@lonnie I don’t use Carveco, so I can be of limited help. I just don’t understand why you have more than one toolpath for a surfacing job. I use VCarvePro, and in it, I set the material size to the size of my spoil board, I draw a rectangle just inside that. Then I select the rectangle and create a pocketing tool path to the depth that I want. I save the tool path as a gcode file, send that to whatever sender I am using and run it.

What is the process in Carveco?

I am sorry grant, miss quoted two designs, one with multiple tool paths one the surfaceing plan. Don’t wanna come across as creating undue confusion, or wasteing any ones time. my mistake.
been laying out numerous designs playing and trying to learn this software.

1 Like

@lonnie No worries, Lonnie. Is the surfacing project the only one giving you grief? As I know you understand, you can’t get much simpler than a surfacing tool path. It just doesn’t compute that there can be intersecting vectors. Or, am I still misunderstanding (A bit dense, you understand.) and the intersecting vectors are for your other design?

yes sir, the intersecting vectors, are for project number 2. but ya know what? i went and kicked a field goal and solved the issue all on my own.(who woulda thought).so i got all the tool paths generated, and saved for that project. the surfacing my spoil board is still a concern but i’m sure its a dumb operater interface problem, and you and heyward are only a shout out away. cant thank you both enough for your toutalige . I’ll keep you informed as the saga continues.

All right, ladies and gentlemen, me and Mr. longmill have been having a good day. i like too think we had us some major breakthru’s this afternoon. So finally got my dumb user interface issues straight and actually created and saved tool paths for spoil board surfacing. exported into U.G.S. and when i go to run it myZ axis goes up away from the surface of the spoil board, instead of plunging down and making a cut. pretty sure this is kindergarden cnc stuff. but i’m hurting my arm patting myself on the back for getting this

1 Like

@lonnie Well, you are moving right along. This one sounds like a Z0 location issue. Make sure that you set your Z0 in Carveco on the same surface as the Z0 in UGS. You can choose wherever you want - surface of your spoilboard, surface of the material, bottom of the material - but they must be consistent.

All that blather said, if you have gotten other tool paths to run properly, it likely is not the issue, and I’m just typing to see myself type. :grinning:

1 Like

ok, i’ll check. i was thinking maybe a post processor issue( dumb user interface) picked grbl inch, when he should have picked grbl mm. but i cant remember how to access that part of the program in carveco, without redoing the whole design. and nope not gonna do that. lol. Anyway i’ll go check my Z 0 in both to make sure. thanks for the feed back.

Lonnie try this: Open a new model; set it to the size of your table/work area; select in/mm; click ok; click on the rectangle box and click on the top left corner and hold down the mouse button and drag it to the bottom right corner; click on create; click on tool path; select the create area clearance tool path; start depth should be zero; final depth should be .1 (or what ever you want); click on add for the tool selection; select what ever tool you have; set the step over to 1/3 of the tool width; set the step down to .1; set the feed rate to 20; set the plunge rate to 1; set the spindle speed to 15000; set the material to 1 (or what ever you want); name the tool path; hit ctrl a to select the vectors; calculate the tool path and run the simulator. Let me know if it worked. If it worked save the tool path to create the gcode file.

morning ollie, thanks for the feedback. and yep took care of it. those be instructions i can follow. thurough and complete.

good day all. With the help of tech support,(kelly at sienci). we figured out the dumb user interface gremlin struck again. settings on my probe module within ugs were way out to lunch. every thing back in line now and machine behaving well. thanks for the input from everyone.