Trouble getting the limit switches to work

I have the switches installed, wired, and was able to figure out how to test to make sure they are connected properly. In trying to home the machine, the gantry has hit the y switch twice and pushed it off the rail both times. The mount bracket is well made but the brass screw inserts won’t stand this abuse for very long. Step 5 in the instructions for adding the sensors says to check on the console for the firmware version installed to make sure it is the latest. I don’t see where this is listed when I connect the machine with the console opened? Can you help me find this?


I figured out how to find this line in the code, which is like reading Latin to me, and the latest version is installed. Then I changed $23 to 3 to get it to home in the front left corner. Now, after homing, when l touch the jog buttons it will only move by clicking the buttons. Steady pressing the button does not move the gantry. Then the red unlock button comes on and it “greys out” when I try to press it. The only way to turn it off, or unlock, is to disconnect, then reconnect the machine and start over. BTW I turned off the soft limit switches until I get this figured out.

I had the same problem with the Jog and keep getting limit errors when trying to run a job. I just took the sensors of for now so i could play around I will revisit.

That is what I am going to do because I had no problems before installing the sensors. Maybe I have missed something in the settings, which for me were difficult to follow. I need a “Sensor Install for Dummies” page.

1 Like

I’ve turned off all switches associated with homing and pushed the button to apply new settings but now I can’t get rid of the Click to Run Homing button.

@Wills , make sure you turned off “Homing cycle enable” in the EEPROM settings using Gsender.
Also, you original problem might also be a EEPROM setting error. I installed my sensors a few days ago. I watched the video and followed the instructions on the website. I noticed that the EEPROM settings in the video were different (and correct) from those shown on the website instructions. The particular setting in error was in the “Homing direction invert” section. X and Y should be on. Z should be off.

Thanks Paul. I was out yesterday for skin cancer surgery, back at the Longmill today. I noticed that X and Y difference also. I’ll continue to work with it today to see if there is any resolution.

I disabled everything, but I can’t get rid of the red Click to Run Homing button. The console shows "error:5 (setting disabled). I have connected and disconnected several times. I am going to Restore Defaults and see what happens.

Okay, that did not help, it’s still there!!!

Last evening I restarted my Longmill. The red unlock button was gone and I was able to run a file! The proximity switches are back in the box for now. So far I can only say that I think the price for them was very reasonable.

I’m glad you figured it out. Maybe you just needed to restart the controller after you changed the EEPROM settings - something to get the Arduino to reboot to recognize the new settings.

Thanks Paul. I am back running but I’ll think I have it figured out when I can get those switches to work as I had hoped.

I just installed these today. I had never used Gsender, so downloaded that, and just hit upgrade firmware since I have an original Kickstarter Long Mill and I had never updated it, it worked fine.

Configuring the switches was, honestly trivial, the default settings, other than the soft limits were spot on.

I had the same proble with the machine freezing on tracing or whatever on a fike I loaded. I realized that the workspace zero I set was too far over for the actual file to work. I will report it as a bug, but there were multiple errors but it would not show those errors or unlock the machine which was annoying, it should at least tell me it was a limit, and I’m not sure why there were two errors either but no matter.