Trying to update firmware and a typo in the docs

Hi Guys, trying to follow your docs to flash the Feb firmware. I noticed a typo here:

" You can check if your firmware has been correctly installed by going to Tools > Serial Monitor. This will open a window to show the console output of the Arduino. If your output looks garbled, make sure to set your baud rate to 152000. As you can see, the output shows the firmware version and build date."

That baud rate should be 115,200.

Also, getting this message when I try and upload:

Sketch uses 29792 bytes (92%) of program storage space. Maximum is 32256 bytes.
Global variables use 1633 bytes (79%) of dynamic memory, leaving 415 bytes for local variables. Maximum is 2048 bytes.
Low memory available, stability problems may occur.

And not seeing any response from the Longboard controller when I have the serial window open. The errors aren’t clear whether I had successs or not, whether they are warnings or not, but I think it did not work?


My mistake, was hitting “Verify” but the question about whether the errors/warnings are important is still true. There are a number of other complaints in the message window too but didn’t want to spam it all.

Also, the changelog just lists a change to support CNCjs. Was there really nothing else? No underlying update to grbl?


GRBL itself has yet to come out with their next stable version, our updated firmware just made a small edit that supports use for CNCjs if you wish to do that.

Thanks for pointing out the typo, I’ve gone and fixed it.

As far as the messages displayed on upload, it’s not something you need to worry about. The GRBL firmware uses up a lot of the Arduinos storage space but is designed to work very reliably regardless. The LongMill version is, if anything, a little bit smaller than the default GRBL firmware, so it will be just as stable. I’ve added this info to the install page as well to inform anyone else who’s wondering the same :+1:

Is there any update on the probe module issue? Both @gwilki and I have noted that the first time you probe after booting up it always fails. And I’ve had random failures at other times. I have learned to ALWAYS double check XYZ zero before starting a job, evening if it looks like the probe completed ok. Is this a GRBL or a Longboard issue?

@jwoody18 Jeff: I think the issue is UGS - at least it was for me. Since I updated to the April 2020 version, I have had no problems at all - no probe issues and no freezes. Touch wood. :wink:

Thanks Grant, will check it out. This goes somewhere on the list below your dust shoe, which is fairly important for me. I’ve been pulling my hair out with the existing one. I just hope my magnets are strong enough. I wish there was a way to do it and not lose any X width…

@jwoody18 I’ve had so many versions of the dust shoe that I don’t remember what I’ve posted here and what I have just emailed to people. The newest version loses no X travel at all. I changed how the steel rails mount on the Z gantry so that they are inside the plate. I’m attaching a pic.

They are attached using aluminum L pieces top and bottom. They are held in place by the top and bottom two 3mm bolts of the Y gantry. It’s very solid and much more compact that the previous version.

It turns out that I do lose about 1/2" in Y, but that is easily addressed by a very small re-contouring of the shoe. (I didn’t think of Y at all until Chris asked me about it.)

Wow! You’ve solved so many of my objections. Any chance I can get these files?

@jwoody18 I can’t attach an svg file. You can send me your email address in a private message and I can reply with it, or I can upload a dxf here. I’m good with either.

DXF here is great. Thank you!