UGS aka Universal G Code sender issues

This is probably not the appropriate forum for this, but I’m going to post it anyway because I am so frustrated. I haven’t used my Sienci Longmill for a good month or so, and yesterday I went to fire up UGS and it just won’t load. It gets stuck on the load-up screen where it says its loading modules and then it just says “done loading modules” but its still on that same screen. And this is on the 32-bit version. The 64-bit version that I normally use won’t even load; it give me some error message that I need Java 1.8 or higher (I have Java 8). I can’t figure what is going on. Anyone else having these issues? If anyone had a good alternative to UGS, I’m up for ideas, because I really don’t like it that much anyway.

@gtrboy77 Dean: If you are not using the August 2020 or newer version, download it and try again. The newest is just a couple of weeks old now.

I can’t speak to any other senders. Others here no doubt will.

@gtrboy77 - Grant and I started out with UGS with a last year version. It had it’s issues definitely. I switched to CNCjs before the updates this year. Grant stuck with UGS and has had success with the current versions. I, on the other hand, stayed with CNCjs and have had not issues with it whatsoever.

So, there are other choices out there. Check this forum for software options as Andy and Chris have posted possible choices. Good luck.

I re-downloaded the current version of UGS and while now the program will load, nothing works. Can’t click on file or any of the tabs. Nothing works. I did lookup CNCjs and I don’t even remotely understand how that works or how to install node.js that is required.

1 Like

@gtrboy77 - Dean, you don’t need to install node js. The layout is very similar to UGS. There are plenty of youtube videos available on how to set up and use. Go to this github web page to see the current releases for downloading Windows, Mac or Linux versions - Scroll down and select the release you need. Then install as normal.

@gtrboy77 What version are you running now? Are you on PC or Mac?

Does UGS connect with your Mill?

I was running the latest version of UGS on my PC. It won’t connect to my Longmill at all. I did download Source Rabbit and got that to connect to my Longmill and ran a program just fine. I like the interface of UGS better, but I’ll probably use Source Rabbit for the time being.

I’ve found UGS gets the port wrong. If you scan COM ports in CNCjs or Arduino IDE you can find the correct port. I’ve had a few instances of UGS trying to connect on COM4 for some reason and getting no response, and then switching to another port as found by another software and having UGS work fine.

@gtrboy77 Dean: go into windows device manager and find the com port that your controller is attached to, then go into UGS and make sure it is set to that port. As Steve points out, UGS will often simply choose the first active com port, without determining that is actually the one that the Mill is attached to.

1 Like

On the 64bit version, you need to tell UGS where the Java folder is located. I believe the file to edit is in the “etc” folder within the UGS main folder. The file name to edit is ugsplatform.conf. Open it with Notepad or Wordpad. I have never had success manipulating with the “Path” command in Windows 10, so I always update this file with the Java location when Java does updates.

There is a line that has a remark called JDKHOME (Java Location) and the physical folder that Java is located. You have to un-remark the line (delete the #) and enter the path to Java.

My Java Path is “C:\Program Files\Java\jre1.8.0_271”

Here is the line with my folder listed after editing:

default location of JDK/JRE, can be overridden by using --jdkhome switch

jdkhome=“C:\Program Files\Java\jre1.8.0_271”

This has always worked with the 64bit version for me - unless your Java install is corrupt for some reason.

Hi, had similar issues a few months back. Boiled down to an issue of Jogamp.exe (a java file) not removing itself once the associated libraries had loaded.
Once your screen loads or appears stops loading at the end of the module script bring up Task Manager. You should see under Apps UGSPLATFORM64.EXE. Scroll down the Background Processes list & look for Jogamp.exe. It will have a series of numbers before & after. (1234…jogamp.exe12345…) right click on it & delete. scroll back to the top & if the UGS screen doesn’t load check for a 2nd occurrence. If it shows up again delete it also. UGS should then load & run fine. Unfortunately this will happen each time it loads. The issue could be with your anti-virus software blocking jogamp from creating it’s need directory.
I had tried removing & reloading both java & UGS, amending the config file & starting in admin mode without any luck & resorted to the above method of starting UGS. It finally resolved itself after both a Java & Windows update. I had contacted the UGS group but never received any feedback from them about the issue.

@gtrboy77 @Rusty_golfer @stevendq

To all: The newer versions of UGS - I think from August 2020 on, include Java in the zip file. I uninstalled the Java that I had installed with the first download of UGS. I wonder - and I don’t know - if some of these Java issues are because of more than one installation of Java trying to run.

There was a discussion on the UGS group about Java and the fact that it is now included in the UGS download. It may be worthwhile to take a look there.

1 Like

I’ve been running the following & since prior issue it’s been behaving aside from the odd user error. :slight_smile:
Product Version: Universal Gcode Platform 20200211
Java: 13.0.1; OpenJDK 64-Bit Server VM 13.0.1+9
Runtime: OpenJDK Runtime Environment 13.0.1+9
System: Windows 10 version 10.0 running on amd64; Cp1252; en_US (ugsplatform)
Thinking about switching to CNCJS when I set up my RPI but despite previous issues I do like the interface for UGS.

I’ve tried most of the solutions above, except the one involving jogamp.exe. It wasn’t running in task manager when I opened it. I’ve uninstalled both UGS and Java multiple times and still whenever I open up UGS, it shows the toolbar and the line with the icons below it and everything below that is blank. I can’t click on anything either. I really liked UGS when I used to use it. I am running out of options to get it to run.

I’m starting to think that it IS an issue with Java. Since UGS comes packaged with both Java and JDK, I see that there is no executable files in those folders, so how do I install them on my Windows 10?