UGS Driving Desktop/Laptop Settings

#1

Some of you guys or gals may be aware of these Windows (or other OSs) settings that can affect the computer sending Gcode to the LongMill. Windows usually installs with these settings that will not be acceptable for running lengthy CNC programs. ANY setting that allows Windows to cut power (hard drives, LCD, etc.) or puts the computer to sleep can cause you problems. When you have long running programs it is possible for Windows to think you or the computer are not doing anything so it will put your computer to sleep or power down some device. Then your UGS is either stopped or interrupted causing it to lose steps. I have run into this problem when there is no keyboard or LCD activity. I don’t think you want to be well into a job and all of a sudden it stops. Depending on what version of Windows you are using these settings are located in your display settings and power settings. I’m not sure if hard drive is in power or somewhere else. I always set mine to “NEVER”. I haven’t seen anything in the forum or Facebook to indicate either the beta testers or the Sienci team experienced this problem so hopefully they will chime in with Yays or Nays if this can be an issue. Have fun y’all.

#2

When your computer is running UGS and sending g-code, the computer will see it as active, the same way your computer doesn’t turn off when you’re watching a movie for example, since it is performing a task.

I have run 30+ hour jobs on several different computers, but the computer going to sleep has not been an issue. That being said, your safest option would be to check your settings before doing a long job.

Hope that helps!

#3

…and make sure your mains power is connected so the device doesn’t think it is on battery and shut down anyway.

1 Like
#4

Or just run out of battery power and crash all together. Thanks for Chiming in Andy.

#5

Thanks for responding Andy. I’m glad to hear that should not be an issue with the LongMill. Just wanted all to be aware that this could be an issue. I understand what you are saying but I have experienced this situation before but not with a CNC. I usually make sure it won’t happen by changing these settings.

#6

If your worried about it shut off all sleep or hibernation settings and don’t close the laptop while your running a job. There is no reason to really.

#7

Another thing to add to your original point @Heyward43, is to look out for scheduled computer updates that may happen during your long cutting job. One of the users on the FB group made a post the other day about how he got a Windows update right in the middle of his sign carving which lost him his project :neutral_face:

#8

Thanks Chris. I saw that and immediately turned off auto update. That one got by me.

1 Like