UGS goes offline during cut

I have had UGS go “offline” during a cut several times. Any thoughts on why? Is there a way to reconnect and continue the cut from where it stopped?

Check your computer sleep settings and turn them all off. That is the only way it would turn off. Your machine should not go to sleep while its running UGS at all. Its weird that it is. But I would start there.

I don’t think my computer is going to sleep while UGS is running. I ran the Longmill a couple of hours today with no issues. I raised the spindle speed from @2.4 to 3 on the makita router. could the router be generating some “interference” while running at certain speeds?

Email the guys at and tell them whats going on.

I think that I am having a similar issue. I am trying to do the Longmill test cut, and everything stalls out at Line 15. The process seems to be read just fine, with the endmill moving to its first location, and the z-axis lowering again, but that is it. I have tried pressing start again with no joy. The footer line seems to count along to 0.26 seconds, but then resets and says it stopped after 0.04 seconds.

I love taking an interlude between rants, because when I get back to my laptop and CNC, Andy has miraculously linked into my computer and fixed the problem! I don’t know what was actually done, but reloading the g-code file allowed it to work.

1 Like

Has anyone tracked down what the problem is with this. I’ve had UGS loose connection mid cut multiple times. All seem to be at random. Each time I’ve been sitting at the machine. Wouldn’t be as bad if there was a way to re-connect and continue the cut but when re-starting the connection the cut head location changes.

@DaveR Do a search here to read the other threads on the same issue. Speaking only for me, I had freeze issues when I first started using UGS. Since going to a more recent version, though, (April 2020) I’ve had no problem at all, regardless of the length of the project. I’m not sure what version is the most recent. I’m happy with this one, so I have not looked.
Also, in the latest version of UGS, there is the feature to restart where it froze. It’s not fool proof, as you need to have some idea of the line number where it froze, but it’s better than nothing. I have not needed to use it, thankfully, but I tested it out and it worked fine.
There is a UGS google group that I found helpful, too.

As something of an aside, what are you using for dust collection? When I changed from using my shop vac to using my shop dust collector, I immediately had freezes again. As soon as I grounded all the PVC, the issue disappeared. There are those that would argue that this could not have been the cause. Fair enough, but I did not change anything else and the problem went away. So, that’s my story and I’m sticking to it. :grinning:

Finally, as has been mentioned in the other thread on this, check your PC settings, particularly if you are running Windows 10 on a laptop. The default power setting in win10 drops the voltage to the USB ports in certain circumstances. Make sure that this setting is turned off, even if you are using a desk top computer. The arduino/grbl controller does not like the lower power.

I’m on a macbook pro and running plugging in. I was using the Oct version, and went back to the April (stable) build. Seemed to be working ok but had it loose connection after the cut was done when I turned my shopvac on that was plugged into the same outlet. I’m now wondering if the shopvac starting up is causing a power surge or interference causing the issue.

@DaveR I wouldn’t doubt that the vac introduced some noise on the motor lines. The guys have put built in noise filters in the controller, but nothing is perfect. If you try some jobs without the vac going and all is well, I think you will have found your problem.