UGS Platform jog control "greyed out"

When installing UGS Platform the jog control, Home Machine and Check Mode buttons are “greyed out”. Entering on command line says “Grbl not finished booting”. Any ideas how to fix this?

I just disconnect and reconnect and that usually fixes that problem.

Thanks - but still no luck

Is everything else still able to operate as usual?

Just in the setting up stage. Arduino drivers needed to be installed manually, but serial port not showing on UGS Platform after installation. Still stuck at this point. Best fix for this?

When you plug the USB in can you hear a ‘connected’ noise come from your computer, and do you see any lights on the Arduino light up?

Here are some things to check/can help:

  • You don’t have Arduino IDE open. Only one program can connect to the Arduino at a time, and the IDE sometimes auto connects to it.
  • Have the controller connected on the computer BEFORE you open up UGSPlatform. It checks your USB ports on the startup.
  • Make sure to refresh and check the ports that you have available. It is not always the first one that pops up.

If you’re still having trouble I can help you check if there might be an issue on the firmware or with the Arduino. Just send us an email.

Yes, the green indicator light and 4 red lights on the Arduino light up. Don’t hear a “connected” noise come from the computer but the yellow connected icon lights up on UGS. Did hear the “hiss and thump” noise once on the CNC.

Right - tried those things but still having trouble. The Arduino serial port is not showing up on the UGS platform. I’ll email you. Thanks guys!

@chrismakesstuff Hi guys - double checked everything again and it works ! All connected! port needed to be manually connected after selecting and verifying correct name of Arduino port. Jog controller and all buttons now not “greyed out”. Thanks for all your help !

1 Like

Excellent @Randy! Very glad to hear that :grin:

Would you mind to explain “manual connect the pirt” I am having the same issue.

Andy will be able to provide you with whatever you need, I’m sure, but this is what I had to do the first time I connected.

I turned the controller on, then went into windows device manager and found the serial/com port that windows identified as being the controller.

In UGS, I clicked the “port” button - the one with the two swirling arrows. That done, I clicked on the down arrow button next to the port window and chose the com port that windows said was connected to the controller.

You only need to do this once, unless you unplug the USB cable from your pc or the controller. Then, windows may assign a different com port to the controller when you connect again.


Hi, I’m having the same problem, could that be because I recently used Arduino IDE once? One day, UGS Platform is working fine, then the next day I practiced programming in Arduino IDE. After that, the issue came up.

@EnriqueG I can’t address your direct question, but I would suggest that you look at windows device manager and confirm that the port that your controller is connected to is com7. That is the one that UGS is connected to. If device manager shows a different port, change the port in UGS to that one.

I have tried to reconnect the USB to the same port and I also have checked the device manager, Port shows COM 7. But still no luck.

@EnriqueG Sorry, Enrique. I’m out of ideas. With no offence intended, ensure that both ends of the USB cable are firmly plugged in, and that the cable did not somehow get damaged. If you have another cable, try it.
As to what you may have done while playing in arduino, maybe someone else here can help. I do my best to leave that stuff alone. :grinning:

Also, make sure to “refresh” the port. Ensure the wires are all tight - don’t just tug at the blue, yellow, green, red wires together, but tug each wire within the colours to make sure they are seated tightly. There were several loose wires that was the cause of the “greying out” for me.

If you have Arduino IDE running at the same time as UGS, you might not be able to connect to your Arduino. It might also be that you accidentally flashed the Arduino with something if you were playing around with it. If that’s the case, you can reflash the firmware by following the steps: