UGS update and more touchplate problems

Hello All.
Yesterday morning I was wanting to do some cuts and for the life of me I could not get the cuts to work properly. I have done lots of different cuts and never had this amount of trouble.
I zeroed X,Y and Z on the lower left corner like always. When I click on the Arrow to start the cut,Instead of the bit going right 2 inches and up 4 inches to start its cut, it just went 4 inches up the y and started cutting the text on the outside line that would have been the profile cut location. I stopped the cut and reset everything, changed the piece of wood and retried and ended up getting the same result. I eventually ended up updating the UGS and manually zeroed and used the paper method for Z. The cut was where it was suppose to be and I finished it and shut it down for the night.

This morning I went back into the UGS and entered the settings into the Probe Module setup as listed on the website for machine setup. I put the bit on the lower left corner and used the touch plate for my Z zeroing. I then moved the router a few inches up and into the middle of the spoil board and clicked on “Return to Zero”. The router came back to the corner but then tried to shove the bit through my spoil board instead of stopping on the top corner of the piece of wood. I double checked the settings and I have everything set like the website said to do it. What am I doing wrong? right now I don’t trust the touch plate and have been using the paper method for zeroing on the other cuts I have done today but there are some times where you need the touch plate and I need to be able to use it.
Any help would be appreciated.


Sorry for the long explanation.

@Troym Troy: When you set XYZ0, did you check in UGS to see if all the axes coordinates read 0?

Can you post screen caps of all the probe settings screens?

Finally, make sure that the probe wires are tight in the green connector, and that the screw holding the wire at the magnet end is tight.

I noticed after the bit was pushed into the wood after clicking “return to zero” that the Z was reading 15.000 I didn’t check before returning to zero because I never had that problem before. That’s when I tried to redo the Z again with the same results.
I just loaded up UGS and zeroed everything and my X and Y are reading 0 but the Z is reading 15.365. I redid it 3 times with the touch plate with the same results. I took pics of the settings and the screen showing the results of using the touch plate. All the screws are tight and when I first put the long mill together I had to cut the tinned wiring off and tighten the screws down on bare wires. I have been using the long mill for about 6 months now and Saturday is when I started having all the problems.

Thanks for the Help

Hi Troy,
I had nearly the same issue last week. Without changing anything (so I think) on the operating system and software, my XY-values are repeatedly ~15000 after zeroing with the touchplate. Tried 3 times, then switched to manual zeroing.
The problem persited even with updated ugs/
java. I neighter solved the issue by now, nor tried the touchplate again…


@Troym Your UGS settings look good, Troy. What CAM software are you using? Regardless of what it is, make sure that you are referencing off the surface of the material and not off the bottom of it or the spoilboard.

I use V-Carve Pro. I have always zeroed off the top of my material, I haven’t come across any project yet that I needed to zero off my waste board. That’s what’s so confusing because I haven’t tried anything new but now its not letting me Zero Z properly. Its really annoying. What would you suggest that I use beside UGS? I would imagine that there are other programs that will do the same job that are set up similar to UGS.


@Troym I’m baffled, too, Troy. If you have the VcP material setting to the top of the material and UGS the same, your settings indicate that all should be well.

As for other code senders, I can’t help much. I’ve always used UGS. I know that others here - including Heyward - have used others. Maybe he will chime in with recommendations.

In the meantime, it may be worth putting a post on the UGS google group forum. I’ve gotten several tips from there.

Oh, one thing. Have you tried just putting the block anywhere on your piece and setting only Z0? (That is, don’t bother with X and Y.) The method of choice seems to be to jog somewhere on your piece. With the bit off the piece, set Z0. Then, use the plate and the probe to set Z0 again. Then hit return to 0, to see the results.

One note on your settings, your endmill diameter is listed as .25, and you have millimeters selected as the unit of measurement. All the other settings are in mm from your pics, so if you are using a 1/4 inch EM, you would need to convert that to mm.

I don’t think that is causing your problem, though. Do you have any “stray” offsets in V-Carve Pro when you do your material setup or G-Code generation?

Grant. I used to do all my zeroing on the lower left corner, a month ago it dawned on me that I can do the Z in the center and not have to do it all on the same spot. Before I had this problem I would zero XY on the corner first, then move to a flat section on the surface and flip my touch plate and zero the Z. Since Saturday I have been zeroing manually and doing the paper method for Z and it has been working with no problems.
Steve. I will change these settings and see if it makes a difference but its been set this way since I first put it together and first set up the touch plate. As far as I know I don’t have any stray offsets. I have done the same cuts for different people and it all cut good before. This is super weird.

If I do figure out what’s going on I will post what I did to fix the issue. Thanks for your time and ideas.

1 Like

@Troym - Yeah, the bit diameter is a minor thing, it just changes where on the corner the bit uses a center. Even then, not super huge.

You zero the same way I do as I switch between Machine Bed to Material Surface for Machine Zero, depending on my job. I use the touch plate to find the corner, then for Machine bed, flip the touch plate over on the bed and re-zero the Z.

It’s weird for sure - so many posts about touch plate and UGS issues in this forum, but it has worked perfectly for me - less operator error, like forgetting to take the magnet off the spindle (the wire connecting the magnet is not very sturdy with it wrapping around a bit as the bit is running) or grinding away at the face of my touch plate because I forgot to use the magnet…

Hopefully one of the other forums can help, or maybe support at Sienci.

@Troym , I know this is late to the game, but did you ever get a fix for this? Like you, I have been using the manual/paper method for a while now, because I never got the touchplate to work properly. I am having issues on long carves where UGS just locks up. I switched to CNCjs, but it locks up as well. I am pulling my hair out about this. I just out a post up about this, and I am wondering if it might be a voltage/control board issue. I say this because it seems like I am getting voltage feedback through the USB. If I hook the USB straight to my laptop, my laptop crashes. I added a USB hub and that problem went away…