Vertical setup - Y axis drift

I just installed the super long board; I am getting the y axis drift again. is there a setting that I can make to correct this?

@Alan Welcome back, Alan.

I’ve moved your post to the SuperLongBoard category so that the solution will be seen by others with the SLB.

In the SLB manual, you will find instructions on how to energize the motors on the SLB so that they will hold position. On the LongBoard, the instructions were to set $1=255. That is no longer the correct way, so be sure to read the new instructions.

1 Like

Thanks Grant!

Here is a bit of the section you are interested in @Alan:

Instead of the old solution of setting $1=255 which forces all motors to hold at full current, two new settings allow you to select individual motors that you want to hold, and what holding strength you want to use. With $37, simply toggle the axis you want to hold while using $210-212 to decide what the holding strength will be (as a % of the motor’s full current).
We’ve found that a minimum of 15% works for leadscrew-driven CNCs. These hold current settings will also apply even if $37 is off when the machine is cutting but that axis isn’t moving. Note that these settings won’t work for an A-axis since that would typically be done using the DIP switches on the external motor driver.

Read more!

Also here’s a new section we added to the troubleshooting section that covers this as well: