Windows x32 and Ras Pi: need some initial validation on completely untested builds

Got the exact same error. Someone built this v7L package with the ARM64 verson of NODE I think. Additionally, there are quite a few lib dependencies that you need to resolve prior to the .deb package installation with dpkg.

Thanks for the feedback y’all - we’re trying out a few new build tactics and will hopefully have a rebuild that covers all the dependancies and rebuilds for ARM32 by this Friday :cowboy_hat_face:

Wanted to get back onto this thread: @jdh , @Rusty_golfer , @Norm310 , @Zmorph did the new release work out for y’all?

yes, I got the appimage to run on my ra-pi 3+ but I figured out very quickly that some of my gcode files are just too big to run with the limited amount of RAM on that model.

I bought a raspberry pi 4 with 8GB of RAM so I installed Ubuntu desktop(64 bit to allow addressing the RAM). I got it a different new error on ARM64. the new error is “Error - /opt/gSender/resources/app/node_modules/@serialport/-bindings/build/Release/bindings.node: cannot open shared object file: no such file or directory!”

First I tried to use the Appimage and got the above error. I thought it had something to do with the way that it is mounted and some dependency. So I converted the .rpm to a .deb and installed it. I got the same error.

Obviously this is the wrong place for this feedback but i just wanted to let you know what I was up to.

1 Like

I got the appimage version to run on both a 3B+ & 4B with no further startup error messages. I use the 4B on the Longmill & did run a few cuts. Had it lock up once at the end of a cut. Interesting it showed 96% complete but the router had gone back to X0Y0 & safe height Z0 & job was finished. Had to reset the RPI. Not sure that this may have been a gSender issue as the screen flickered at the same time. I haven’t had a chance to play any further & it will be another week before I can get back to the Longmill.

1 Like

I did try the new release, after making the appimage file “executable”, it worked flawlessly since! Thanks for the hard work much appreciated.

1 Like

Alrighty, this is all good info to know, thanks guys :slight_smile:

@jdh this is an existing issue we thought might happen but had yet to see it occur so good to know what lead up to you receiving that error. @Rusty_golfer and @Norm310 glad to hear the new version is working out for you so far!

I downloaded the 0.6.5 version this morning and have the same error with just a slightly different path. Just to let you know.

1 Like

Hi, For some reason since ver. 0.6.4 & including the latest I’ve been encountering terrible lag in the Visualizer with my RPI 4B with 2GB. Small files it is tolerable but on larger files the time lag gets so back it is even effecting the gSender window to the point it freezes. Ironically the code runs just fine & will complete the job & return to zero. I either have to shut down gSender or wait till the program catches up in 5+ minutes. I did up my GNU setting from 128 to 512 with only minor effect. It’s now at the point that I either have to go back to UGS or swap out for a windows machine (it didn’t have this issue) which I don’t want to do. No other changes were made.


For the time being I’ve switched back to Windows as well

I would really like to go back to the raspberry Pi.

I too have had a lot of performance issues

But it’s kind of the bastard child right now with all of the other stuff being fixed

However with six. Eight and maybe 6.9 it might be stable enough to switch back