Windows x32 and Ras Pi: need some initial validation on completely untested builds

Hi all! An update today on new gSender builds being available :slight_smile:

Normally I’d put out an update email but today the update is happening within the forum since we’re not highly confident that these will actually work seeing as we’ve done no testing yet on ras pi and only a brief session for Win32.

If any of you had been waiting to try out gSender on either of those platforms then I suppose now’s your first chance! I have to disclaim that similar to all other BETA versions of gSender to-date, but especially on these builds in particular, you must understand that if you download and build from the provided links below that you understand that the software is provided as-is with no guarantee against incorrect or unreliable operation.

Windows 32-bit (.exe):
https://drive.google.com/file/d/1tsIT7A-SOwhhTFt-Ip8OadeZLWHnSOJ0/view?usp=sharing

Raspberry Pi (.deb and .rpm):
https://drive.google.com/file/d/1VHVYmMjdyMC6bsLlAbXiU5Hep_LK3izu/view?usp=sharing
https://drive.google.com/file/d/1sz9Mgf03JbXmUnygc0M20WpuSEhIElwG/view?usp=sharing

If it’s not your cup of tea to try out a wholly untested program, that’s totally cool. Next Friday I’ll be putting out a more stable build for these systems via the gSender BETA tester email newsletter, so sign up to be a BETA tester if you’d like to be a part of that :cowboy_hat_face:

BETA Signup: gSender Closed BETA sign up

I’ll tag some people to this post that I know expressed interest in trying one of the new builds: @blats @tillig @Heyward43 @carmine80 @HAWWK @billkaroly @David @DMarconi @JCB @alanbabb @drewgraham80

Feel free to submit feedback either using the feedback button in the toolbar of gSender or in this forum thread!

Sorry @chrismakesstuff but all my systems are Win64 and I don’t have any RPi systems. I can’t help.

1 Like

My bad Heyward, thought I’d seen you mention your interest. Hope you have a very swell weekend :grin:

1 Like

@chrismakesstuff , I downloaded the deb file & installed it on a RPI3B. There were some initial issues installing the RPI software. (RPI OS being pissy)
When I attempted to start gSender from the Accessories menu I got the hourglass, no error messages but neither did it load to the screen. Noted that gSender is pointing to a gSender library file in the opt/gSender directory.
Task manager showed 8 gsender files loaded but no activity.
I then pulled the sd card from my RPI4 that runs UGS & the Longmill & tried with different sd card (didn’t want to crash my present setup :wink: ). Again same issue, attempted to load but stalled out before anything showed on the screen.
Not sure if I missed something but will keep trying.
Russ

1 Like

Thanks for the heads up Russ, would be curious if the rpm file may also work for your setup. Perhaps if you notice a difference between a UGS or CNCjs setup and gSender, then that could point us in the direction of what we might’ve missed in the build

Didn’t have a chance this weekend but I just finished a design to cut soon (next weekend?) so I’ll sign up for the beta and get this bad boy installed. Yay, RPi!

1 Like

As I am just getting going with my Longmill, I will pull the Pi version once you get to the “tested beta” - too many variables on my end for me to be any help. BUT - Will there be a way to flip the screen to vertical orientation in the Pi Version? If so, can you possibly clean up the display as the layout (especially) the motion / jog wind needs a little help (boxes and data are truncated). Thanks

@chrismakesstuff, I tried to load using RPM but was getting error msg that it was unable to complete due to a folder of the same name being in place. This was from my attempt to install the deb package earlier. Then reloaded a fresh RPI OS (Ver 5.10.17 V7) & tried to load the RPM file with Alien but got an an error msg stating architecture armel not supported for my RPI. Went back to installing the deb package & tried the 3 GL drivers (non-gl; fake KMS & full KMS) with no joy. Program still stalls out after loading. This all using my RPI3B.

1 Like

I might have some time to get this on my RPi in the next day or two. I’ll be using the .deb on RPi 4, but my RPi is entirely headless, so I’ll SSH in and install… but then what? (I admit I could poke around and probably muscle my way through here, but it would help to just get a couple up-front pointers…)

  • Is there a command to start the server?
  • What port is it going to be listening on once it starts?
  • Is it going to install as a service so it starts up on reboot? If not, is there a recommended way to do that? (I’m using the crontab method for CNCjs right now.)

Thanks!

I Will try it first thing tomorrow, thanks

Hi Chris,
Same thing here - headless on Pi 4 with bCNC currently installed. You mentioned an updated .deb release might be released this Friday so hoping to focus my energy on that version. Any helpful guidance for installing on the Pi would be appreciated.
Thanks

Hi all, just wanted to put out a quick update here (in combo with the email I just sent out) that since we’re still waiting on more feedback regarding Winx32 and Linux/Pi operability and the testing on our end has been very slow the planned “big release” for today is going to be pushed back at least a week but probably two. This should give us the time we need to get a little bit more feedback and bugs tested, as well as run some more verification on our end.

The focus for the “big release” will be to have completed everything that could be considered practical and baseline for a respectable g-code sender, including some more guidance and how-tos on gSender, builds for the remaining OS’, and making the download of gSender publicly available.

With all this being said, I’ll be really watching out for all continued feedback from all existing BETA testers to give us the what’s what on what difficulties or suggestions they still have for gSender

Chris, tried to get the deb version to work. Will load but nothing on screen. Tried on both an RPI4 & 3B with fresh RPI OS & also tried to load using Ubuntu. No joy. Not getting any error messages just hour glass for a bit then nothing although files are showing loaded & running in Task Manager. I know that with the RPI4 & using UGS I had to delete the VC file in OPT to get the Visualizer to work. It made no diff for gSender. Unless someone has an idea of what needs to be tweaked I’m stuck with UGS.

Thanks for the info @Rusty_golfer , we’ve got two Pis on hand and will be doing some investigation of our own this coming week. Will post more info if we find anything on our end :bug:

If we can get a little info on what we should be looking for on RPi (where it installs, what we should expect to do to run it, etc) just to get us started, is be a tough more inclined to help out on the early beta there. Thanks!

I’ll do some testing this weekend on the raspi thanks guys

Found some initial issues were some libraries not loaded. Started again with a fresh OS & after copying the Deb file to the Pi Downloads directory I then ran “apt-get install ./gSender_0.5.7_armv7l.deb” from said directory. No errors & appears all libraries needed downloaded & installed. The gsender icon came up on the screen when I clicked on the shortcut in accessories. Nothing else happened. reset with new OS & did same but using GDEBI to install. Same again re: icon then nothing. Note: on reboot on both tries the icon would no longer come up on the screen.
Russ

1 Like

So… Have been using gSender on windows machine with little issues. Tried install on raspi4 and only get splash screen. task manager shows gsender running in several instances but app dosent fully load. Noted others are having same issue.rpm and deb versions are same. running raspian on raspi4. did install on terminal and with package install. uninstalled and re installed several times. Hope to use raspi for controlling my various projects and excied abuot running on a Linux machine.

1 Like

raspi4 not working for me, other than splash screen and the app doesn’t start or load properly. Even if Pi is my favorite way, the actual package is not ready and really supported. Hopefully coming soon!

Hi, Loaded a fresh RPI OS then installed the latest (0.6) version of the armv7l.deb file. Got the following error:
" ERROR -/opt/gSender/Resource/app/node_modules/@serialport/bindings/build/release/bindings.node: wrong ELF class: ELFCLASS64! "
Icon showed up in first instance but after reboot just error.
Russ

2 Likes