Y-axis not moving at same rate

Hi all!
Newbie here. Finally assembled my 30x30 MK2 but am having problems with my y-axis. The one on the left seems to get stuck at a certain point as it nears the front. See video.
Here’s what I’ve tried/checked so far. What am I missing?

  • jogged it all the way to the back to “reset” it and moved it forward. Still happens.
  • tensioned and retentioned V-wheels on both axis. Can turn the v-wheel by hand but it’s difficult.
  • can turn both y lead screws by hand. These are fairly easy to turn but both seem to have about the same resistance.
  • mounted on 3/4” MDF on a solid table. Everything is perfectly square. The two Y-axis are parallel. Front dimension between metal feet 890mm. Back dimension between metal feet 890mm
  • dip switches in control box seem to be ok. All set to on-off-on-off (1-2-3-4).

What’s missing?
Video: MK2 movement. - YouTube

1 Like

@DaveU Hey Dave, welcome to the forum. You are a few weeks ahead of me (still waiting). I am sure somewhere will chime in. If you figure out the solution on your own, please post the solution for other new people can learn too. Again, welcome!
Jake

@DaveU I’ll second Jake’s welcome, Dave. :grinning:

I can’t see in the video. Do you have limit switches installed?

No limit switches installed.

@DaveU A couple of things to try:

Back off the anti-backlash nuts, then snug them only enough to take out the slop.

Loosen the bolts holding the anti-backlash nuts to the gantries, run the Mill front to back, then re-tighten.

If you have not already run the calibration program in gSender, try it. I know that you said that your Mill is perfectly square, but it can’t hurt to confirm.

I’ve completed the instructions and the problem persists.
I thought the calibration program had to be run from the front-left and wasn’t able to do it because of the problem I’m having (the left y gantry can’t reach the front…misses it by about an inch).
So I tried running the calibration test with starting point closer to the middle of the y-axis. The results tell me to move one of y-axis by 0.02mm.

It did however update my EEPROM settings as such:
$100 xsteps/mm 201
$101 ysteps/mm 199

made the changes and the problem persists, but might be a little better

@DaveU Dave: Did you get your Mill working correctly? If not, I suggest that you open a support ticket with Sienci.

Before doing that, you may want to reverse the Y motor cables to see if the problem moves to the other side. You can add the results to the information that you send Sienci.

Didn’t get it working properly.
I’ll open a ticket

1 Like

Just to wrap this up in case someone else runs into this. One of my potentiometers was on the wrong current. Used these instructions to fix it https://drive.google.com/file/d/1W5DsebUjvdz2V3tNGy0WAdh2pKzJbU50/view

@DaveU Good to hear that you are up and running, Dave. Tks for posting your solution.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.