Z axis doesn't hold position and plunge into the work

I’m not sure what I did wrong here but my Z axis is easily pushed down with one finger even under tension. What makes it worst is that during jobs the weight of the spindle and the vibrations are enough to make it plunge and it starts plunging a few seconds into the job. It’s a new MK2 Longmill 30x30 I’m setting up so no prior behavior here.
Jus to be clear, it doesn’t look gcode related. The same thing happens if I move the spindle myself through gsender Jog Control commands.
I’m using a chinese 65mm dia., 110v 1.5kw air cooled spindle that doesn’t seem significantly heavier than the recommended router. I wouldn’t think it’s a weight issue. It was my assumption that when under tension the motor would resist hand powered motion. Is that the wrong assumption?
If anybody ran into similar problem, I’d appreciate any input.

@jbf What do you mean when you say it is “under tension”? Have you set $1=255?

I mean when the longboard is powered on and electricity reach the motor. In my limited experience with stepper motors, they’re usually harder to turn by hand when electricity is flowing.
It is most certainly an abnormal that the z axis would move down on its own during a job. At any moment I can push slightly down on the spindle carriage and the lead screw will start to turn and the carriage move down. The moment there’s any sort of vibration in the structure the z lead screw start turning and the carriage go down under its own weight.
What do you mean by set $1 = 255?

@jbf Since the weight of the spindle you are using is bringing the Z axis down, you should set $1=255 so that the motors are always powered. If you are using the default settings, the motors are not powered when they are idle.
Search on this forum and you will find previous discussions on this issue. You will also find the disadvantages of keeping the motors powered all the time.
Adding a spindle to the Long Mill is also discussed in the Sienci Blog here. As part of that installation, Andy advises setting $1=255, among many other things

1 Like

Thank you. I found the section related to this issue. I’ve read this page before and somehow managed to miss it. My spindle is ‎3.32 kg compared to the 1.77kg Makita router but for me reducing noise level is most important.
I’ll try to dig some more into the forum about the issue.