1.4.2 and latest bug on $11 and $12

i had some issues recently where my cnc didn’t work correctly or at all. it turned out to be the settings on $11 and $12 not accepting 0.010 on both , it only accepted 0.01
i never changed those settings ever, i was in 1.2.2 i upgraded and it worked on 1.4.1 but none of the latest versions
the search for the issue can also be found here

This was unclear from the other thread. Are you saying that gSender 1.4.2 changed those settings without your knowledge?
That doesn’t seem likely.
Typical defaults for those are
$11=0.01
$12=0.002

no what i’m saying is that my controller board does not work if it’s is like follows:
$11=0.01
$12=0.01

i can not change like it should be and the way it works on 1.2.2 up to 1.4.1 as bellow, notice the value behind ( . )
$11=0.010
$12=0.002

For what it’s worth, 0.010 and 0.01 are the same number.

I’ve also verified in 1.4.3 that I’m able to change $12 in the firmware tool to 0.002 successfully so there doesn’t seem to be an issue with that part of the application wrt rounding/minimum values.

I’m still a little confused what exactly you’re experiencing - are you saying it’s a problem with the firmware tool or something else?

1 Like

basically machine does not run if it’s 0.01 only runs on 0.010 , the stepper motors basically turn very slow with hard vibrations
so then if you can select $12=0.002 why would it not let me select it i tried on two similar but different vendor boards
here’s a video with the issue i have

1 Like

OK, so you’re seeing an issue with the firmware tool on your side. We’ll take a look for the next releases.

1 Like

That video made the issue more clear, thanks.
In the meantime, send
$11=0.01
$12=0.002
through the console.

1 Like

Every time you say it’s bad, you add a zero to the end of 0.01. Are you saying the added zero is the problem and there is no problem if the added zero is absent?

Or vice versa …

Why not be clear?

i tried, does not take it

0.01 bad
0.010 good
clear now?

Is this a parsing problem?

@KGN

You tried in the console?
What happens? Do you receive an “ok”?
Can you show a video of that?
I just downloaded 1.4.3, and I see the weird issue with the firmware tool, but the console has no issues taking new values.
The console commands are passed directly to your controller.

Ok, so I upgraded just now from 1.2.2 to 1.4.3, and it does work. I did use the console to change the values.
Apparently the problem was somewhere in the latest versions, either 1.4.1 or 1.4.2

@iuliancalin I’m pleased that you were able to resolve this, Iulian. I’m closing the topic as resolved.

1 Like