A problem with G sender, I think

Sorry but I’m a nubie even with this posting stuff, not sure i’m doing it right or not.
I just got my machine together not long ago and I’m having a problem with gsender locked up with alarm 12 (Z limit switch), it won’t unlock no matter what i do. I have even unplugged all limit switches. I have windows 11, gsender 1.4.7 and the SLB
I have even reloaded gsender.
Does anyone have any ideas, i want to thank everyone ahead of time

What CNC machine do you have? Is this a new build, or did you replace an older controller with the SLB.

One thing I’d suggest (regardless of machine type) is to check the firmware settings in gSender regarding both hard and soft limits ($20 and $21).
When I initially set up my machine, these were enabled, and nothing moved. I had to turn them off to initially confirm things actually moved, then I enabled the hard limits to test the switches, and then after setting my distances, (in $130, $131, and $132) I enabled and tested the soft limits.

Not sure that this is your issue – but worth a shot.

John


1 Like

Hello JohnOCFII
your suggestion didn’t work, but thanks
I forgot to tell my machine is a Longmill 48x30. I got it just as the slb was coming out so I got in on preorder of slb, so i chaned out original board with slb when i got it. To get back to problem. I have 2 windows laptops with gsender on them and problem is the same on both , like i said i even unpluged limit switches from slb and gsender still has alarm 12 and stays locked up. In firmware #21 it won’t even let me turn off hard limits. Could it be something wrong with the SLB? I have also had problems with probe trying to jam bit thru the auto probe block .Like I said i’m new and have no idea!!! John or anybody know whats going on?

This is a shot in the dark but have you tried unplugging the SLB from the power for a bit? Disconnect it from the laptop as well, not sure if the SLB gets any power from the PC but the original did. Leave it unplugged for a couple minutes to make sure any capacitors drain stored charge.

Worth a try, I think.

@_Michael
It didn’t work I’m sorry to say. I unplugged it overnight. I checked the Z sensor with metal wrench, it lights up so I guess it’s good. I wonder how you get GRBLHAL into USG or openbuilds control?? Maybe they would work at least long enough to figure out whats wrong with the thing! I been thinking about going back to original controller and see if could get past alarm 12!
David

1 Like

@dmhouston

That’s too bad. I was hoping that it would give a ‘clean reboot’ of the SLB and maybe allow you to change firmware settings.

Have you tried contacting Sienci directly? I’ve never had to but I’ve heard good things about their customer support. I wouldn’t expect a reply on the weekend but it might be a good idea to submit a support ticket now so it’s ready and waiting.

Best of luck, and welcome to the group David.