All settings lost after adding sensors

I have ran into a new issue after installing the Sienci’s x,y,z sensors. All was working fine with the install. But everytime I would home and zero then try to go back it would be out X 1.0 Y 1.0 Z 0. So I tried adjust the bounce back from 1mm to 0.5mm to see if anything would change. Applied my setting. Ran the homing and the z when to the top and buzzed. Hit the stop and had to restart Gsender edge(also tried all this in reg Gsender). Now the only settings I have are the homing switches. Everything else is blank/zero and it will not let me make any changes. I tried to flash the prom as that was a fix last week with another random problem. It will connect but wants to home but will not move. Most likely the -791mm/sec acceleration rate. How can I get my eeprom to back? It’s also showing my space a 2million. I added a photo. Not sure how to get my controller to factor settings as flashing it from Gsender is not working. Also if I use the independent reset buttons it will not take the setting.




@Parrott I"ve moved your post to the gSender category. There is a dedicated group at Sienci working on gSender and they monitor this category.

As a thought, after, you flashed the eeprom, did you then click on the restore defaults? Also, be sure that your machine profile didn’t get inadverently changed.

That option “Restore defaults” is greyed out also greyed out and not able to be used. Same deal with “Appy settings”

I think that if I were in your situation I would try a different program to flash a hex file.

I have two options to do that. You can use XLoader, Windows only, to flash the board and this is the easier of the two options.
Screenshot 2024-01-05 090350
Like in the pic you will want to set the device to Uno(ATmega328) and then select the COM port and open the hex file with XLoader and then Upload.

XLoader.zip (678.3 KB)
GRBL-LongMill-Firmware-Sept-8-2021.zip (310.4 KB)
The firmware above is the most recent I could find for the MK1.

The second way is to use the Arduino IDE as outlined here. That page is where I got the firmware from by the way. Using the Arduino IDE is a little more involved than XLoader but Sienci has provided good instructions on how to do it.

I assume that your machine is a MK1 because that’s what is set in your pics. The instructions for a MK2 and firmware can be found here if you need those.

EDIT: I forgot to mention that with XLoader you don’t need to install it. Just extract it to a folder and then run the XLoader executable that is inside.

1 Like

Thank you. Will update once I have got back to the shop

1 Like

I was able to get everything back up and running. Use the Xloader method. Was short on time and had to use the MK2 Hex file. There was no Hex file in the GRBL file linked. After running Xloader with the MK2 firmeware file I then flashed with my MK1 30 x 30 selected and was able to restore the defalts :slight_smile: Thank you again.

1 Like

Not sure what I did wrong with the download but I’m glad you got it sorted. I figured that if you got anything grbl to flash that gSender would then work to flash again :grinning: