Arduino or Long Board Damaged? Maybe both?

I have a MK1 LongMill 30X30 from the KickStarter in 2019. It’s just for home hobby work, so it does not get daily work-outs. I recently came back to it, after a couple month hiatus, and could not get the system to run for more than a few seconds. Gsender will connect to the controller for a short while. I can usually jog the axes a few times or even run a few dozen lines of g-code, but then it locks up.

When it locks up the indicator in the Visualizer usually goes to “Disconnected” but the device connection indicator in the upper left still shows it to be connected to COM3. I have also had a few incidents where the controller will respond VERY slowly to command: Issues three or four move commands from Gsender, and the controller executes them with a 3 - 10 second delay between commands.

I have also observed some message traffic on the console with nonsense characters (diamond with a question mark in the middle). This seems to happen randomly as the controller responds to command. Then once the whole things crashes, I see some status messages with a a bunch of nonsense character every 5 - 10 seconds)

The USB power settings on my laptop are set to stay on until the apocalypse.

Trouble shooting steps I have tried:

  • Shorter USB cable - no effect
  • Unplug my dust collection and fume fan - No effect
  • Unplug all the steppers from the - Gsender does not lose contact with the controller, but still get nonsense characters occasionally
  • Reseat the Arduino - No effect
  • Flash the Arduino - Gsender just hangs
  • Different Arduino (Name brand Uno, but it has been rattling around for years and may not be in great condition)- Message traffic on the console looks normal, and Gsender reports the expected motion as long as the Arduino is loose, or installing in the LongBoard with the driver power off. But, it fails to drive the steppers. The steppers will hum continuously until a command is issued, then they go silent while the command is “executed,” but they don’t move
  • Chucking the whole thing out the window - Tempted, but did not try it yet.

I’ve pretty much hit the limits of what I know to test. I see strong indications the Arduino is damaged. But the replacement I have did not clear the fault. Any thoughts before I buy a whole new MK2 Controller?


@Tralgar You have pretty much covered all the usual suspects. The only other things that I would try would be to try a different USB port on the PC. Also, ensure that the Uno is behaving by talking to it in the serial monitor on Arduino IDE.

I tried other ports on the same laptop and on my desktop PC with similar results.

I got this response on the Arduino IDE Serial Monitor when I started up, so I’m confident I have the right firmware:
Grbl 1.1h [‘$’ for help] LongMill MK1 build Feb 7, 2022
I also got a full status dump in response to “$$” and and “OK” when I sent move commands. The conclusion seems to be the LongBoard has failed in some fashion beyond my ability to troubleshoot.

So… I guess I am ordering a new Controller :frowning:


@Tralgar I’ve passed along all my meager advice, Joe. Before ordering a new long board, I would open a service ticket with Sienci. We may have missed something and it can’t hurt to ask them. You can include a link to this thread in your ticket request so that they can see all you have done. Nothing to lose.

Please post back when you have this resolved. It could help others and will, at least, add to the collective knowledge base.

1 Like

I forwarded all this to Scienci Support, including some console logs showing the nonsense characters. Jason replied the next day with:
"It looks like the firmware is corrupted in the Arduino, it could be a simple fix by flashing the firmware or it might need a new Arduino. The highlighted area shouldn’t look like that. "

I managed to flash the Arduino from my desktop machine. I’m pretty sure this is at least the second successful attempt to re-flash (there were a couple of failed attempts as well), but I did not keep great notes until recently.

When I reassembled the controlled and reconnected it, I was able to jog it all over the place without locking up. I loaded a reasonably sized file (~7500 lines). It ran for about 8-10 min (<50%) then locked up again. After that, I went through various levels of restart and reboot of the controller. I logged everything I did and captured Console Logs and screenshots every time it stopped. There were several instances of nonsense characters, delayed response from the controller, and dropped connections.

I just sent my data over to Jason to review.

In the meantime, a MK2 controller arrived last night. I’ll drop that into my system and see if I get better results this evening.

Success!! It was the Arduino. The Long Board does not appear to have any issues.

I replaced the Arduino with the new one provided by Jason at Scienci. Hooked everything up this afternoon, and ran a few quick jobs on GSender. The MK1 controller Now works perfectly.

I still have the older Arduino board. From everything I can tell, it works just fine for other applications. I’ve loaded it up with a few basic projects I had laying around and it appears to work. I suspect that means I am just not loading up the right driver or channel that is causing the failure. I’ll keep it in the project bin for the next questionable/risky project I have.


p.s. It only took 30 - 45 min to replace the Arduino and get back up and running. Unfortunately, I have been traveling for work, so it took me a month to get back to this project.

1 Like

@Tralgar Good news, that, Joe.

I’ve marked your topic as solved and will close it. Go back to having fun. :grinning: