At my wit's end

Ran a job yesterday and had this happen:

I’ve had issues in the past with jogging on the y axis and GRBL connectivity. Tried running the job again this morning and the same exact result occured.
Any ideas?

That looks like a lead in. Check your the parameters in your tool path to see if there’s an option to add a ramp I or lead in movement to the beginning of the program. If it’s enabled you can disable it and that should take care of that

No ramp or lead in added to toolpath.

To clarify, that’s where I ended the job.

Well that changes some things. Can you describe what you mean by the jog not working a little more? Is it that the z axis isn’t coming up of the part when it reaches the end of the program? Or that it’s coming up in a ramping motion? If that’s the case look at the g code, if you can, and follow the end of it to see what’s going on. It could be that the program thinks that where the actual cut is ending is when it should raise the z axis. If that’s the case just delete the extra movement and move the z retract to when the end of the part is. Example. If you are making g something square and you start at x0y0z-.25 and also ends here look at any code beyond that point an delete it if it’s not needed. Add a g01 z.5 then on the next line add g00 and what ever your xyz axis’s home coordinates are.

Oh and remember to add in the spindle stop command too if you’re using a spindle set up which I believe is m00

@toddg Since it is doing the same thing every time, it would seem to be toolpath related. Can you post your gcode for members to look at? If this is a vectric file, upload the .crv file, too.

1 Like

Spindle speed?
Depth of cut?
Endmill type?
Dust collection?

Here are my job files:
Desk Leg Cutout.gcode (193.3 KB)
desk.crv (975.5 KB)

Some machine specs:
48x30 Longmill Mk 2
Feedrate: Vectric default, 45 in/min
Pass Depth: .075
1/4 Downcut Endmill
Using the Makita router, so spindle speed is…3?
No dust collection currently.

A brief synopsis of the issue:
Booted up the machine and everything connected just fine (I’ve had issues in the past). Hooked up the auto-zero touch plate and got a good zero. Everything went well for about 20 min/1500-ish lines (near the end of the first part) when the machine went off course as seen in the above photo. Stopped the job and turned off the router. Tried to send it back to XY zero but I didn’t lift the Z axis enough to clear a clamp I had in the lower left corner, so the bit ran into that, grumbled for a bit, then stopped. Moved it back to start by jogging, and this is where I noticed that the Y axis was skewing during jogging- the right side was moving more than the left:

Note that the left side is at about 3.5 in and the right is at 5.
Shut down and went into the house to send this up to Jason at Sienci Labs.
Next day, I tried again. Same result: movement ok, zero ok. Started the job, went off course at pretty much the same point. Tried to re-zero and restart the job, only the zero was off by about 1/4 to 1/2 an inch towards the back of the machine. Also, the offset jogging was back. So, I gave up and started this post.

Thanks for your help, guys. I do have diagnostic files from before and after the original run if those would be helpful. They’re on my other PC, so let me know and I’ll post them later today.

PS- this issue occured with another job earlier:
Ladder hooks.gcode (17.9 KB)
Ladder hooks.crv (426.5 KB)
Job ran the first two parts fine, then went loopy cutting the third part.

@toddg I’ll just address the issue of re-starting after you hit the clamp. You don’t state it, but I’m assuming that you ran the X gantry all the way to the back so that the LM would square itself.

This has nothing to do with the first issue, but the LM will not square itself automatically after we do something to throw it off square. You need to run it to the stops and listen to that terrible grinding noise to be sure it’s back to square.

I’ll leave to others to analyze the gcode. I ran it in simulation and it looked fine.

I looked at your .crv file, though. It looks like you are cutting these in plywood. IMHO, your feed rate is much too slow for that router speed and that bit. These parameters will not cause your issue, though. They will likely cause burning of your cuts and heating/dulling of your end mills. Just a FWIW.

Thanks for the input! Is there a difference between running it to the back vs running it to the front?

I agree with @gwilki that you could be dulling your tool due to low chipload.
The main thing I’d look at, and the reason I asked about you’re endmill and dust collection… With a down cut endmill and no dust collection, you’re just packing chips into the cut. With nowhere for the chips to go, you’re recutting them and adding to the necessary cutting forces. When those forces become more than your machine can handle, you lose steps and get results like what you’re seeing.

1 Like

Not as far as I know. :grinning: