Auto touch plate alarm

I’ve been having issues zeroing with the auto touch plate. I get an alarm 4 98% of the time. I try everytime I start up but has only worked a few times and with a few different bits

I have connection I pull the wires away from other wires as best I can however I still get the alarm.

I’ve searched the forum however I haven’t seen anyone post their resolution.

Please help


G38.2 (what gSender uses for probing) means that the GRBL firmware expects that the pin isn’t triggered at the start of a probe cycle. If you are getting an alarm 4 right as you initialize a probe cycle before any movement, that means GRBL thinks the pin IS triggered, and is likely some variation of the following:

  1. Check your EEPROM $6 setting (Invert Probe Pin). By default, it should be $6=0. If it’s $6=1, change it to 0, the toggled off state. You can either use the console for this ($$ to see EEPROM settings) or the firmware tool.

  2. Check the status report in the gSender console by sending a status report by typing “?” with no probe continuity (so the probe block is not in contact with the router bit). You should get a report back similar to “<Idle|MPos:0.000,0.000,0.000|FS:0,0>”. If the report back also includes a “P:NP”, that means that GRBL is reporting the pin is triggered. It might be your ground and probe wires are swapped, dirty, or shorted, and you can try to fix that.


  1. Noise in electrical line. Make sure your probe wires are away from all other power/stepper wires and try again.

Try these steps in order and let me know what the result is. Probe cycles not running for this particular error is almost always an issue with the physical installation if it’s not the firmware option.


I believe you meant $$ instead of ?? to see EEPROM, I just checked in gSender console to make sure.

1 Like

Yup, that’s on me typing before the coffee had time to percolate :sweat_smile:

Hi Kevin.

Thanks for the reply!

I checked the EPROM $6. It’s set to 0

I checked the status report. Everything seems fineProcessing: IMG_20221102_180030.jpg…

Here is how my wire is run. Does it look like it would cause issues?

I double checked that the wires aren’t swapped. We have connection or the green light wouldn’t come on at all. Which eliminates a short…

I’m lost. Any ideas?

Quick update.

I’ve been playing around a bit more and im still getting alarms however it’s working more often now.

Part of my issue seems to be that I didn’t have the bit close enough to the plate before starting the probe cycle.

Still looking for advice to make this process run smoother.

Thank you!

Hello. This issue has been resolved. My issue was not having the bit close enough to the plate before starting the probe cycle.

Thank you for the help!

1 Like

That should result in a different alarm number. Maybe 5 off the top of my head.
Are you sure you were getting Alarm 4?

Yes it happened again today. I lowered the Z a bit more and it worked.

Seems odd to me how close the bit has to be. It seems to work around 3 mm above the plate

Can you capture the console when you get a probe fail?

Sorry super new is that the “?” command?

No, just the console output when you probe and it fails. It should show something down there.

Heres a screenshot. I had a few days of no errors. But this is what comes out

You should be able to probe 25mm without issue. If you’re getting an error 4, it probably throws the error as soon as you start the probe sequence, correct?
Sounds like you might have some sort of electrical issue… Hard to say exactly what the issue is.