Calibration via gsender

Good Day! I have my MK2 up and running, well kind of anyhow. It moves well, I have the wiring secured down and was ready to do Garrett’s “break in” before doing the spoiler board. When I ran that code, the right Y axis bound up and made one heck of a noise. So I stopped and began to attempt troubleshooting. I approached it that maybe the unit wasn’t as square as I thought it was. I ran the gsender calibration multiple times and got a different answer each time. The results were between 1.3mm to as much as 4mm. So I thought my old eyes were playing games with me. I measured with a digital calipers.

Please keep in mind, the unit moves without issue when using the controller on the gsender software. No grinding or anything. I did use a small amount of 3-1 oil on the bearings and lightly coated the lead screws.

So my question is how to approach the squareness issue, and how to best proceed. I am quite excited to get this machine up and running. The build quality seems amazing.


Hi Jake.

I had similar issues when I first got my MK2 up and running. The first problem I ran into was calibrating in g sender, it would tell me to move the left side forward or the right side back, I would do that and it would be farther out so after trying to adjust it by taking the screws out and moving it again I remounted the MK2 on a couple skids with slots so I could easily move either the right or left side Y rails. After all that I ran the calibrating program again and it was off by a bit, I moved the amount like it said and I was twice as far out of square, so my thinking was g sender was telling me to move the y rails in the wrong direction, I moved the left Y rail back to where it was then moved it in the opposite direction by the distance it said to and it worked fine. Said I was .002 off after running the calibration program again. I can live with that. I tightened every thing down and checked the diagonal just to be sure and everything was spot on. Put screws in the skids and was done with that.

Then I had a problem with the gantry jumping out of square after getting really frustrated I called Customer Support and talked with Jason, he was a lot of help, Ty Jason! I was able to turn my lead screws by hand with no effort at all(not good) and he suggested adjusting the gantry all the way forward till both sides came in contact with the front supports, it will make some noise as the gantry gets perpendicular with the Y axis, that’s OK, then adjust the Delrin anti- backlash nut assembly just to where it was hard to turn the lead screws by hand and that took care of the problem. He also sent me the link below. I hope this helps

Good luck.


@MikeH THANK YOU! My issue is that the gsender calibration isn’t consistent and it has you change “steps per minute” each time which further messes with the calibration and makes troubleshooting it very difficult. If it were accurate, meaning I get the same response every time I ran the calibration tool, I would move my y axis. I ran it twice this morning and got the following responses:
First Time: .63mm right Y backwards
Second Time: 1.94mm right backwards.
Now the one good thing is it is telling me to move backwards on the right side. But one would imagine that it would be at least CLOSE to each other. I guess my digital calipers could be off… but it is highly unlikely.
Maybe I will call Since and talk with Jason and see what he has to say. I appreciate your assistance and quick response!

Jake at this point I’m not sure about g sender that’s why after I did the calibration I checked the diagnostically and it was spot on but that was only after I realized that the program as telling me to move the y axis the wrong way. Also I highly recommend mounting the unit on two sleds with slots in them. It makes the alignment soooo much easier.

Here is a picture, I cut 2 sets of slots (way longer than need be lol) on each sled for both right and left axis. On the underside of the top of my stand I put t-nuts in so I could loosen the bolts just far enough to move the Y axis and snug them up when done. I also put screws in the sleds after everything was setup.

@MikeH Thanks Mike. It will make me unbolt my long mill from my table anyhow to put the slots in. I do like the idea and it would have been much appreciated if Sienci would have suggested that in the first place when assembling the table. I believe you are spot on with your solution. I think I may just do that to my right side and leave the left side alone. See if that will help me. Like I said earlier, the calibration tool isn’t consistent. Makes me hesitant to move anything, but know I will need to in order to solve this problem. I need to call Sienci anyhow this afternoon, as my Long Mill blows my GFI’s in my shop. At first I thought it was the power strip, so I went and bought a new power strip. Still had the problem. Then moved it to a dedicated one outlet circuit that was designed for my table saw. It still blows the GFI. What is unclear to me if it is the power block or the control board that is causing the issue. Well I guess it could be a motor too. Haven’t tried exploring that yet.

As I stated before, I greatly appreciate you taking time to respond to my issue. I am very appreciative!