Cant jog, but connects fine?

I´ve got a homebuildt grbl machine, and I can connect in gsender, but not jog?? It must be some simple setting, but cant figure it out? In the firmware tab, there is a profile setting with different machines. I dont see an option for homebuilt, could that have something to do with it?

I really want to to try gsender. I use UGS now and it works fine, but gsender just looks more nice. :smiley:
Thanks in advance’


Yes, Thomas, the machine profile settings are significant. You could try different profiles (under the Firmware tab) to see if one of them is similar to your home built machine. I haven’t tried to, but I suppose one could create a unique profile.

Just be safe and look at each parameter and compare with what your machine requires.

There’s no option for create a profile. But gsender says it supports homebuild machines, so there must be someone who has experienced this… :smirk::sweat_smile::person_shrugging: It looks like it has imported my settings. They are the same as in ugs… :relaxed:

have you typed in some commands manually to see if the machine even moves?


Couple points of clarification:

The machine profile selection in firmware just informs which image to flash or default values to restore. It has nothing to do with the settings shown there - those are the settings in EEPROM on your board currently. That’s why it’s the same in UGS - it’s just showing the value currently in your EEPROM.

As to not jogging, we’d need some console output to see what error (if any) you’re getting. Be aware that we use $J jog commands, which require GRBL 1.1 - if you’re running an earlier version on your homebuilt machine they won’t execute.