Can't launch gSender Appimage

Hey folks,
I’d love to play around with this software. I have a RPi 400 with 64bit debian installed. I can’t get gSender to launch. I downloaded the 64arm version and set to anyone execute, but only splash graphic appears and then nothing. I left terminal open and here are the error messages. Any thoughts? I’m not great with linux…

12:57:25.449 › Error: /tmp/.mount_gSendepf3DrM/resources/app/node_modules/@serialport/bindings/build/Release/bindings.node: cannot open shared object file: No such file or directory
at process.func [as dlopen] (electron/js2c/asar.js:140:31)
at Object.Module._extensions…node (internal/modules/cjs/loader.js:1196:18)
at Object.func [as .node] (electron/js2c/asar.js:140:31)
at Module.load (internal/modules/cjs/loader.js:981:32)
at Module._load (internal/modules/cjs/loader.js:881:14)
at Function.Module._load (electron/js2c/asar.js:779:28)
at Module.require (internal/modules/cjs/loader.js:1023:19)
at require (internal/modules/cjs/helpers.js:77:18)
at bindings (/tmp/.mount_gSendepf3DrM/resources/app/node_modules/bindings/bindings.js:112:48)
at Object. (/tmp/.mount_gSendepf3DrM/resources/app/node_modules/@serialport/bindings/lib/linux.js:2:36)
at Module._compile (internal/modules/cjs/loader.js:1145:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1166:10)
at Module.load (internal/modules/cjs/loader.js:981:32)
at Module._load (internal/modules/cjs/loader.js:881:14)
at Function.Module._load (electron/js2c/asar.js:779:28)
at Module.require (internal/modules/cjs/loader.js:1023:19)
(node:1965) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
Checking for update
Update for version 1.0.5 is not available (latest version: 1.0.5, downgrade is disallowed).

I recently purchased the pie for with the keyboard. The RPI 400 and I bought the extended package which basically included everything including a pre-built OS

I will post the link of the version that I installed and you can try it from there. Mine works perfectly

For what it’s worth, at the same time I installed UGS and it’s working as well

Just for s**** and giggles. Maybe you should try installing UGS and see if it’s the OS or the app

Unfortunately it didn’t work for me.
I have the RPi 400 and I’ve tried installing both 32bit and 64bit versions of linux and tried every combination of appimage from gsender github. Alas, the furthest I get is the gsender splash logo. It says on the wiki that there will be an error regarding the update, which I get, and that you can “click through” but there is no way to do this that I can discern.
Any help would be greatly appreciated.
I should add that I was able to successfully install and run bCNC on linux bullseye.

Not sure how to display the version of the OS I have installed.

If you know let me know and I can type it out

1 Like

lsb_release -d

That will show current OS install.

Tell me 100% truthful I am running an Arduino Uno board that was sent to me by sienci.

I just recently sold my 30-30 and I’m waiting for my 3048 to ship

But that said, I have been running that Arduino board as my controller in my 30-30 and on the workbench so I know it’s a valid scenario

Thanks for all the effort. Yes, you’re running a 32bit version of debain, buster. I’m playing around with the 64bit bullseye.
The other thing that I discovered is that the RPi 400 has an ARM8 chip or aarch64. I downloaded that version and am currently trying to get it to run, but can’t figure out which icon to use for launching the app. Strange that there is no instruction for this.

I will say back in the beta there used to be an installer and all kinds of fancy stuff

The last time I ran it, you basically just run the the application you download. I’ll take a picture of the icon I created to launch it but it’s nothing complicated

I do remember somebody from the Dev team saying that it has to be the 32-bit version of Linux. I reported some bizarre problem and I can’t remember it was a month ago

I created this icon/text file myself

If I remember correctly there are instructions someplace. Basically you have to download it, change it to executable and it works