Close to being done with this machine

Using good wood, glue ups etc and this machine just failed again, tired of it.

Carved a top right corner, bottome right corner and then clunck, clunk clunk and it startted caving in the wron place. Should have gone to lower left, didn’t move correctly on the x axis to the new location and ruined another piece, what’s funny is this wasn’t the first carve with this g code, I give up.

Don’t give up! If you have isolated it to X axis movement check every thing associated with the x axis: loose screws, V wheel adjustment, anti-backlash adjustment, stepper to lead screw coupler set screws, stepper motor cables, tension on the lead screw. It should work.

1 Like

I had problems early on and eventually found it all caused by the connection to the x axis stepper motor not being seated fully. It would work grand for 2 or 3 jobs then bug out then start working again. Finally unplugged it and reseated all the stepper motor connections and voila its been working hard ever since. Very frustrating but if you stick with it, the reward is well worth the investment of time. Good luck !

1 Like

Thanks for the advice, the cost in wasted wonderful material & time is frustrating.

@Bill FWIW, Bill, and I know that it’s not worth much, I’ve been where you are and I managed to hang on. More than one time, I told my wife that I was “selling the damn thing” and buying a dog. I’ve ruined projects that ran well for hours and went nuts in the last few minutes. Many times when I thought that I had finally found the problem, I proved myself wrong after a couple of completed projects, after which things went FUBAR again. Now, I’m like the alcoholic that has been clean for a while. I’ve done quite a few projects successfully. My fingers are still crossed.
Most of the Mill owners have had no issues at all. I envy them. At least, though, you and I have the experience of having problems and solving them. What’s the saying, “that which doesn’t kill you makes you strong”? If that’s true, you and I are damn near herculean.
Hang in there.

1 Like

Grant, thanks again, and again, and again, you know how this is gonna end, makes a pleasant song lyric.

It is me I’m sure of it, its not just the mdf practice cuts after the air cuts, then I get the nice wood on it and what the heck, am I jinxed or what. I maintain it, check it, my wife and I laugh when it plays the little tunes, I swear it sound harmonic that it is asking for some tlc.

Same gcodes,as before,did a 2hr 45 min carve, preceeded by an 11 hour carve, carved the back of this project no issues, carved the front, all seemed well, then like I said clunk, didn’t move on the x axis to the next corner and started carving 1/2" to the left of where it had just finished.

I monitor the stepper motor temp and the x axis motor gets a lot warmer (118° f) than any others, I was wondering if anyone has increased the size of that motor in particular? Let me know if you’ve heard of that. I do run a fan on that side.

I wasn’t thinking of a dog… yet

@Bill I’ve never thought of checking the motor temp, and not thought, either, of changing out the motor. I’m sure that you have checked everything multiple times, but could it be that the X gantry wheels or the anti-backlash nut are too tight, causing the motor to work harder? Depending on the project tool path, I suppose that it could simply be that the X gantry is moving more than the Y gantry, too.

What do you have the max speed of X set to? The default is 4000. Do you have grbl set to keep the motor powered on at all times?

I just did a search on our motors and the specs say that they are designed to work in high temperature environments and if I am understanding the specs, they can operate at a temp of up to 150°C, so much hotter than yours is getting.

@gwilki I have never changed feed speed anywhere, I am now using g sender and when I observe the carve, if hard material, ie Maple or even some of my recent Walnut I will slow the speed down to 70-80% feed rate, I look at the chips. I run the router at 13000 to 14000 rpm, I have no clue on where to check the max X speed, also no clue on where to check grbl motor powered on.

When I was going through one of my previous failures I started checking everything, that’s when I discovered the temperature difference of the motors, I had a hand held temperature meter from my tube amp building hobby. I bought and installed new wheels, have not changed the anti-backlash nut. When going through my setup with Kelly @ Sienci she reloaded the controller firmware and she advised that the tension on the anti-backlash should allow the screws to be turned by hand with some but not too difficult effort to be turned by hand, I originally hand things more loose, but still had similar issues. The wheel tension is set when lifting up the gantry’s I can turn the wheels with some resistance. I truly dislike this subjective part of the setup, tight, but not too tight, loose but not too loose etc.

I can carve many projects without fail in many different materials then clunk, got a fail.

@Bill If you have not changed the feed rate or the motor power on setting, both will be the default set my Sienci when they flash the Uno in the controller. For fun, any time that you want to see the settings, just enter $$ in the console window.


In G sender clicking on settings it’s 750 mm, I design projects with v carve pro in inches, could that be an issue?

I had been using UGS Platform but switched over to G Sender, so other than settings not sure where to do the $$, I can check it in ugs platform if needed.

@Bill No. The gcode sets things right. That said, what post processor are you using in VCarve, grbl inch?


Yes, grbl inch is what I use

1 Like

Project Pic Realtor thank you gifts

Did the center, Top right, lower Right then glitched

@Bill I can’t see the “glitch” in the pics. What happened?

Post the gcode if you like. I can run it.

I was just showing the project I had run prior to the glitch, that one was successful as many are, then the glitch, it carved correctly the center, top right, lower right, then moved about 1 half inch from the lower right and started carving to the left of that lower right position, sorry I sanded down the failed piece attempting to recover the work. I did successfully carve the top and lower left later. I am talking about the mosaic emblems, not the text.

@Bill Understood, Bill. In VCP, before you create your toolpaths, are you running the vector validator to make sure all is well? I went for quite a while not doing that, and after having some weird failures, I posted to the Vectric forum. I uploaded the crv file and some guys there pointed out flaws in my design that ended up being the issue - even though it was intermittent.
I’m grasping at straws here, but thought that I would ask.

Good morning Grant, yes I run the vector validator when it pops up creating the tool path, this project had none, to add to the mix I had carved this before with no issues. I am going to pay more attention to the mm / inches for both G sender and VCP., I read somewhere that may cause issues. I am using VCP 10.514

1 Like