CNC making erroneous moves


First post - having a bit of a struggle…

I really like Jay Bates design for a spoilboard so I bought his plans thinking I could just modify as needed for the Longmill. Well, after a few hours I gave up and decided to create it new myself. I am trying to scratch the 4 corners on the table of where I will be positioning my 49" x 32" spoilboard.

When trying to determine where I should zero my router at the lower left hand corner (how my job setup is in vectric), I cam up with x=2.445" and y=1.468" based on driving the unit to the lower left, zero out XY, then checking the travel lengths when driving top right.

Since I am quite nervous about wasting all my effort to this point, I ran the gcode without a bit. The lower left and upper left corners seemed great, but then I got a grinding noise when getting to the upper right hand side, like I was traveling too far. After finally going through the motions, moving to the lower right, doing that quick carve, I got the same grinding motion with no router movement. After a couple of seconds, I shut it down. Gsender showed the router was supposed to go back to the home position, I think. Now my zero is reset at the lower right hand corner.

I have had several instances in my testing around where the motors are whirling but the machine isn’t moving.

I just tried the same operation again and this time it got stuck at the top left cut and motors started whirring with no movement.

Any idea what I am doing wrong? Any help would be appreciated.

Thank you,

Welcome to the forum @Cropduster16!

This leads me to believe that something in the drive train is slipping intermittently. It’s usually the coupler between motor and lead screw. What happens is say the machine slips on a move to the left then later it will run into the right side because the machine is not where it “thinks” it is.

So I would check those couplers and make sure the wheels and anti-backlash blocks are adjusted properly. If you have gotten that grinding noise when not at the end of the machines travel then the wheels/blocks might be too tight and causing it to bind.

Thank you for your reply.

I have adjusted everything including the extremely difficult to get to anti backlash nut for the x axis. I got about 50 holes done and then it didn’t move again. Something is definitely not correct with my x axis. Frustrating.

Also, be sure you have selected the correct machine layout in gsender. I was having a similar issue the first couple of times running a border test run. I have a 30x30 and found the definition was set for a 24x20. I made the change, restarted gsender (just to be safe) and haven’t had issues again. Of course YMMV or if it’s set correctly there may be other sources of the issue. I like to start with the easiest things to check first and work out from there.

1 Like

Thank you Don. I will definitely check that.

Before calling it a night, I tried loosening the bolts that hold the x axis anti backlash nut in place. I must have overlooked that. Well, I have been successful up to this point. I’m now 90 holes in with no issues!

Thank you both for the insights - greatly appreciated!

1 Like