Compatibility with FluidNC

Hello,

Really love using gSender, you have done a great job with the development.

I realize gSender is compatible with GRBL, and FluidNC is based on GRBL32. Would it be possible to add compatibility with FluidNC?

Thanks

1 Like

Hello Tyler:

Welcome to the group.

I have a Longmill myself and I currently use FluidNC with gSender 1.1.1. Naturally some features of gSender are not required as FluidNC maintains its own configuration files. gSender lacks WIFI so unfortunately I cannot use my smart devices (Ipad and Iphone when using gSender ) but other than that it works fine.

Hi Andy,

Thanks for the reply! I’ve been able to use gSender with FluidNC in the past on a TinyBee board.

I’m currently assembling an Openbuilds Lead 1515 and have a Spark Concepts XPro v5 on the way. I’m hoping it will work with that as well.

I’ve been able to get gSender to work with FluidNC in the past by logging into web portal on the control board and resetting the firmware. It’s a workaround.

Just hoping FluidNC will be supported natively in the near future!

Hi Tyler

gSender is by far one of the best senders for the arduino microprocessor and I will continue to use it on my dedicated longmill 762x762mm laser. Moving forward with my new “PrintNC” project I have decided to use Barton Drings FluidNC and his ESP32 6 pack controller.

Hello,

you can try this modify gSender:

The reset behavior of gSender has problems. In my setup, it would not connect to FluidNC at all because the JavaScript serialport module that gSender uses opens the port in a mode that results in the ESP32 restarting into bootloader mode, where it is expecting to upload new firmware. I solved that by modifying gSender to explicitly issue the proper hard-reset-into-run-mode sequence. I will tell the gSender folks about this. Meanwhile, if you want to patch it yourself, here is an easy way to do it without having to do a full recompile of gSender:

Edit the file C:\Program Files\gSender\resources\app\server\index.js - to do so you may need to edit as Administrator, or change the permissions on the file so an ordinary user can modify it.

Round about line 10242 you should see the line:

    _this2.emit('serialport:open', {

Just before that line, add this:

    _this2.connection.port.set({ dtr: false, rts: true });
    setTimeout(function() {
        _this2.connection.port.set({ dtr: false, rts: false });
    }, 300);

Save the file and restart gSender, and it should connect to FluidNC properly. At least that worked for me (and Bart too).

It worked for me perfectly, no Reset is needed anymore to connect!

Short update, since 1.1.7 the mod above has not worked for me anymore. FluidNC runs on a evalboard on my machine. This evalboard uses the dtr and rts conneciton of the USB to serial converter to send the ESP into programming mode. This causes problems with the inital connection with gSender. Because of this i removed this connection physically on my eval board and leave only the RX ant TX pins of the serial line connected to my ESP. Now i synchronize gSender with FluidNC by typing $Bye into the console after connecting gSender to the serial port. This works perfectly for me!