Connecting xpro v5 to g sender

Hi, I am trying to connect my xpro v 5 to the g sender. It says it is connected in the top left corner and when i pull the usb cable, it disconnects. But when I look at the upper right corner of the viewer it says its disconnected, and the jog is grayed out. It has worked previously on my adruino so i know the program works. I have tried different baud rates etc, doesnt seem to help. Any ideas?

Why are you pulling the USB cable?
Maybe I’m misunderstanding?

@nastyfast44 Welcome to the group Mike. I’m guessing that you pulled the USB cable just to see what would happen, then you plugged it back in, yes?

What make and model of CNC are you running?

I’m wondering if the issue could be that the xpro v5 controller spec says it is running grbl_esp 32 ver. 1.3a.The Sienci controller is running 1.1h. Also, I believe that gSender is written to work with arduino-based controllers and it would appear that the xpro is not arduin-based.

I don’t know if these differences have any effect on gSender. I’m just throwing it out there.

Yes I was pulling to verify if it would disconnect. I am running a queen bee pro. I built a cnc a year ago with ardriuno and it worked with that. But is not with the xpro. Your specs are correct. So I’m assuming that may be the issue. I didn’t realize they were that different. I figured they were both using grbl and that they would function the same like ugs… but I may be mistaken

@nastyfast44 I’m going to move this thread to the gSender category, Mike. The Sienci techs monitor that board very closely and will likely chime in.


Try issuing a soft reset (default keyboard shortcut is %).
See if that allows you to connect. Not all controllers are designed with a reset on connection, and I think that gSender expects that.

Yes we haven’t tested on this firmware yet so that’s likely why you’re not having success with connection. As of yet gSender has only been set up to work on pure GRBL :+1:

1 Like