Continued issues

Stopped again, machine moved to last cut on the y-axis, I let it sit, it again started to move to the lower - y-axis then stopped, no more movement at all.

The yellow position cursor continues to move even if the machine doesn’t.

@Bill Looking at your dust collection, I have a suggestion. When I ran the same flex hose, and didn’t ground it, my machine would freeze frequently. As soon as I grounded it, all was well.

It’s easy to test. Simply remove the dust shoe and the attached hose, put up with the dust for a couple of jobs and see if things work out. If they don’t - well I’ve been wrong many times before. If all is well, you can easily fix the problem.

Will give that a try tomorrow, thanks for the response.

Ok, removed dust collection hose, machine stopped again, this time got the alarm. Taking guide chain apart to remove router power cord. I am now going to begin systematically eliminating areas of possible interference.

Damn! I’m grasping at straws here, Bill, but does the USB cable that you are using have chokes on it? How are you running it? Is it in the drag chain? I believe others removed the router cable from the drag chain and it helped.
This sure sounds like electrical interference.It’s just finding the blasted source. (Obvious, I know.)

Edit. One other test: run the program with the router turned off.

Got the thing back together, running it again using source rabbit as the sender. Router power cord out of the guide chain, no dust collection, plugged the laptop into a different source. Good news is I am learning my way around this thing.

Yes on the usb cable, about 15 minutes from the furthest yesterday max it did. Still running.

USB was never in or near the drag chains. I am wondering about the mills power supply and the laptop ps, they are close maybe 6 inches apart. Those two ps bricks are mounted under the tosion table top, I made my table tip vertical for space saving, not a huge shop.

finished the first run, cleaned up the mess! Cut the unused portion off the spoilboard so it is now the correct size. Actually buggered it up in a few areas, reinstall dust boot and making another run with the dust collection attached to see if that’s the original issue. will let you know how it goes. still using source rabbit, makes me wonder what the issue was. Grant I appreciate your help!

1 Like

Wow, finished second surfacing pass, no issues again, Bill +2, long mill +/-0 that was with dust collector hooked up.

It’s always good to get a little up against the machine.

Guess I will start putting the rest back together but not today!

Thanks again for the assistance!

1 Like

UGS usually shows which alarm triggered, source rabbit too?

Bill, I was going to suggest static too. I had a few random issues with it early on as well. Not sure what I did to resolve it, I still haven’t gotten around to grounding my vac hose, but I haven’t seen it crop up in months.

My machine PSU is half way between the floor and the table, at the moment, sitting on a stack of MDF. Not by design, it was a temporary-permanent solution during setup, but it is quite a distance from the controller itself and the laptop PSU.

I did added inductive sensors to my machine which I highly recommend, having repeatable homing and stopping end stop crashes is a must do in my opinion. I did put a simple $15 4 relay, 5V board from Amazon between the sensor triggers and the XYZ sensor inputs on the LM controller to avoid spurious noise triggering them, but if you don’t have sensors enabled that’s not an issue for you for now.

Out of curiosity, is the vac near the machine and on the same circuit? Just wondering if it or something electrical nearby in the garage might be causing some interference?

FCC/Industry Canada testing & certification marks are all about avoiding these kinds of issues between electronics - but more and more products are creeping in to North America, especially from China, without having these required tests so I think we’ll be seeing more of this in the coming years. As it is, even tested devices can be problematic. Your phone is not supposed to make your speakers sing weird songs when you sit it near them either…


@Jeff I am already learning that stopping would be better than crashing, my vac system is outside in a garden shed along with the compressor. I actually ran it today without problems but have not put the router cord back, still using source rabbit, I would really appreciate knowing more about the sensors, plan, youtube?

Had a nice day today, did some experimenting with bit sizes, fonts and even a little clip art. Still so much to learn. My ugs still doesn’t see comm ports, used source rabbit and all seemed fine. More to try tomorrow. It does make me wonder what happened to platform. No pauses, stopping or hesitating.

By the way, if you’re having issues with stopping randomly, I would also recommend double checking that all of your default settings are correct on the machine as well. More info here:

Thank you, not having the stopping recently but good to know if it reappears.


I am almost done my sensor project. I added them to the X, Y and Z up quite a while ago and wouldn’t be without them. I recently solved my issue of how to do a Z down sensor (where the heck do you put it?). Let me get that install completed and I’ll take some photos for you.

I didn’t understand the differences relative to a CNC at the time and got normally open (NO) sensors. Normally Closed (NC) have the advantage of being able to be wired in parallel and alerting you if they fail (as they fail to the Open position) so you know if a sensor is down. If I was doing it again I’d get NC of the same ones I have (inductive), otherwise I wouldn’t change a thing. Love them and wouldn’t be without them. I think they are a must have for any CNC.



I made some videos for you so you could see the sensors. More in this post: Inductive Sensors for Homing and Limit Detection

Thanks Jeff, will have a look.

Just a thanks to all that helped, I have actually carved quite a few items, all seems to be working ok now. I have reassemble everything and still working. I did switch to V Carve Pro and reinstalled UGS Platform and it sees the comm port and all is well. Now on to more carving!

had a little time today so thought I would attempt to solve the static charge issue. What I did was solder a wire to the internal spring of the hose, ran the wire down the inside of the hose and soldered it to the other end of the spring, left some wire hanging out and put a banana plug which I then plugged into a ground on power strip. gave it a try on some scrap mdf with my surfacing bit and it seemed to help a lot. no more dust gathering on the hose so possibly a fix or at least a help.