Controller stops communicating

My machine quits communicating randomly. I have controller on it’s own circuit,no vacuum or other equipment running, both rails and controller have a seperate groung. I have set laptop usb and screen savers to never and i checked all wiring connections.Ferrite filters are in place,and i can wiggle usb cable ends and it doesn’t do it. tried 2 different usb cables also. While i was doing this i bumped controller with my hand and it stopped communicating. Had to power it down and replug usb at machine to get comm back. I then held usb at machine and bumped it again , stopped again, restarted. Acts like a bad solder connection inside controller. Has anyone had this issue? Also bought it June 2022, date on controller is august 2020.

@rbasford The arduino is held onto the driver board only by the friction of the pins. On the used machine that I bought, the arduino was almost completely unplugged from the driver board. You may want to check that in your controller.

EMF? Maybe try a USB extension cable to rule out bad connection at your computer usb. I also use a laptop running gSender Yes, I jiggle everything. Have not thrown the Longboard on the floor yet to check for loose cons… maybe double check those

Support also had me check this , it seems in place and tight

Already tried new cables and a powered hub to boot. ??? i’m lost

machine has ran flawless for 2 months…really like it.

So it ran flawless for two months and then what changed? Stupid win update?

not sure ,I I have a dedicated laptop with no internet access,only used for machine. Now my auto probe function is gone? I must have gremlins

@rbasford Another thing to check is the power switch. The older units had an issue and the solution was to bridge the switch. An easy way to check it would be to bump it again. You know that it will lose connection. Now, you need to see if the power lights go out when you bump it. If so, the switch is bad.

Sweet, none of my CAD boxes have internet access so that rules the cloud stuff out.
And good point @gwilki , @rbasford what version Longboard do you have?
Yes, pesky gremlins…
What are the ferrite filters for?

I have the Longmill 30x30 MK2, Sienc had me reflash and restore defaults, ran 6 minutes and quit. No bumping switch does not do it and no it does not loose power when it does it. The ferrite filter just helps with any A.C. noise.
They are thinking possible bad board.

Pretty sure they’re closed for the night now, Hopefully they will contact me again in morning

Will you post your file with tool paths so we can rule that out?

I did the “dry run” that checks the gcode and it found no errors, besides that it does it on multiple files even the ones I ran in the past that worked fine.

funny thing it stops in different places on the same file also, I worked for Trane doing Building automation and programming for 20 years,i’m used to working with controllers and have seen alot of board and firmware problems, I’m pretty sure this is a firmware issue.

1 Like

@rbasford First welcome Ray! Good people (as you have seen) here very willing to assist. Didn’t see this response anywhere in the thread, do you have another laptop to try? I was having problems and when I switched to an old laptop I had sitting around, everything seemed to work. Actually, it is a Mac from 2011. Just adding this, although you probably are correct, a firmware issue, or possibly a bad solder joint.

Please make sure you put the solution when you find it, here so the rest of us can learn as well. Once again, welcome!


1 Like

Lately, I too am having connectivity issues.

Dedicated laptop, disabled Windows updates, disabled Windows Defender, disabled sleep/power down, no internet connections, no other virus programs running in the background, tested multiple USB cables, spindle wires are shielded, motors have shielded cables, no vacuum be used, have not updated GSender for quite some time, no need to update because of how well it was working & I didn’t need anything more from GSender.

GSender worked almost flawless for a few months now. Lately I give the laptop & controller time to get stable then I feel more comfortable to start a file, then do some casual jogging to verify connection is stable, but lately this approach has not worked. All looks well & good then it disconnects & when I do several different things to reconnect it it quickly connects then quickly disconnects again. I even have closed out GSender & re-started, with no difference in get a successful connection.
Then, out of the blue the connection stays stable with no problems for the entire cut file/evening.
Never sorted out what made the re-connection successful.
This is very annoying & I am loosing faith in GSender.
My controller & transformer are mounted in a stable/consealed environment, so nothing gets jostled, bumped, or vibrated.
Been looking at these forums for a while now with no firm/concrete answers.

I too had the same issues as yourself and RustyR and made two seperate trips to Scienci Labs in Kitchener ( I live close) and I also made several calls for help. Jason from Scienci was excellent and we communicated over the phone and he also took control of my computer (laptop) and checked numerous areas that may have been causing the trouble, with no luck. On my last trip to Waterloo Jason hooked my laptop and longboard to one of their computers and it worked just fine? We agreed, I would return home and check out each connection to the motors and longboard. He sent me back with a replacement power supply in the event this was the problem. I disconnected everything and went through the labourious task of checking each connection and replaced the powerpack. Guess what? It began working like a champ.
I was very fortunate to have found the problem (power supply) but I can’t remember ever being so frustrated. There are so many areas that can fail and all I can recommend is to keep working at it. Had I spent a ton of money on another CNC I would have been pissed but the guys at Scienci are dedicated and want us to succeed with our projects and communication with other fellow CNC’ers be a positive one. They will resolve your problem. Don’t give up.

Worked With Jason from Sienci. He was great,explained everything I tried , He had me hook up Voltmeter and check powersupply when it happened, everything was fine there . I found a spot on the board cover that if i tapped with finger it would loose connection everytime. He had me pull the board and check the board connections they were fine also. I took a short video of it happening and he immediately shipped me a new board. First he had seen this problem…a fluke I guess. Support and Jason were great. Got new board installed today and running a 3 hour project, about 2 hrs. in and no issues at all.

@RustyR Rusty: I was about to close this thread since rbasford, who started it, has resolved his issue. However, I see that you have/had a similar issue. Have you solved it?