Deep cuts on end of first pass

So I got my new longmill all set up did a couple of quick cuts and all is good.
I design a wasteboard a d start cutting. First pass is good. Second pass the through holes dont line up. So I restart from Zero and it does deep cuts.
I’m in need of some help. I have looked at the code with a visualizer, I have tried different programs, I even did the Microsoft turn off and back on again thing, with both the computer and the longmill controler.

Then the start of the second pass it started to cut deep( the not so straight line)

When I reset to Zero and try again it only cut deep. That would be the straighish line.

Any help would be greatly appreciated.

@r_heisler Welcome to the group, Richard.

I’m sure that we will collectively figure this out, but a little more information will help us along.

  1. I assume that there should not be any “straight line” cuts, correct? You are just doing a series of shallow pockets to take T-nuts, then centre holes all the way through the spoil board.

  2. What software are you using for the CAD/CAM part of this project?

  3. What gcode sender are you using?

  4. Are you using the Sienci plate to set all three 0 axes?

  5. Are you using the same bit for the pockets as for the drill throughs?

  6. What is your sign? (Just kidding. Enough questions for now, I think.)

  1. Yes it was going to do the center holes and drove of course. using Aspire for my CAD/CAM.

  1. I was using UGS, and also tries Openbuilds Controler

  2. Yes I was going to use the same 1/4" bit for both pockets and holes

@r_heisler If you like, post your crv file and I can take a look at it. As you undoubtedly know, this is a pretty simple file, so with luck, the issue will be easy to spot.

When you create the toolpaths, since you are using the same bit for both operations, did you create one toolpath, or one for each of the operations?

Yes I created 2 separate tools paths. For the wasteboard. And I even checked it with a gcode viewer.

new wasteboard 32 by34.gcode (1.5 MB)

I am hopeless reading gcode. Others here will be much better. I can look at your aspire file, it you like.

I tried to look at it. but i have no idea what I’m looking at.

it wont let me upload the crv3d file.

I forgot about the file type restrictions. I’ve send you a private message.

A few random thoughts. How did you “restart from Zero?” If you hit the “reset zero” button in UGS that would be a problem. Did you reset X, Y and Z zero with the touch plate after you turned everything off and on? You did need to. Is it possible you bit slipped in the chuck after setting zeros? Looking for simple answers/solutions.

1 Like

I reset to Zero by manually jogging back to home, then clicked the zero reset in UGS. I did not turn every thing off an on the first time but did the second time. Nothing changed.
I did check the bit and it was still tight.

Rick: I’ll just repeat here what we discussed in our emails - for anyone else looking at this thread.

Since you are using the same bit for both toolpaths. you do not want to reset anything between toolpaths. When the first one is finished, open the second one and run it. You already have XYZ0 set from the first toolpath.

The only time this would change would be if/when you change bits. Even then, you don’t touch X or Y. They are already set. You reset Z0 to account for the different bit length.

1 Like

Thank you to gwilki for all your help today. I’m sure we have this problem fixed.
I will make a post soon after I try and do a couple of cuts.

Well I got the deep cutting fixed. It was just the way I had my settings inputted.

But now I have a alignment issue.
My holes that were set on a grid of 2", did not come out at 2" from the top of my Spoilboard to the bottom the holes are skewed about 3/8". And from left to right about 1/4" difference.
I noticed when the Y axis is moving there is a clicking noise. And the lead screw is tighter than the left side.
Would this cause my problem with the skewing?

@r_heisler When do you hear the clicking noise? Early on, I was getting a clicking noise when the wheels on the Y gantry were passing over the delrin supports holding the rail. My wheels were too loose and it allowed the gantry to be low enough to lightly hit the supports. The clearance is very tight.
Another place to look is the locking nut on the end of the Y lead screws. The locking set screw on some of them can touch the bearing. I see that the new locking nuts are longer to address this. I added 8mm washers between the nuts and the bearings to prevent this.
If one lead screw is markedly tighter than the other, it can skew the gantry. There are no hard and fast measurements for the tightness of the wheels. I imagine if they are close, that’s close enough.