Edge 1.3.3 keyboard shortcut bug

I have 7 macros that do nothing more than set a dimension in the Z axis. Of the 7, 5 work as expected. For two of them, if I run the macro from the macro tab, they run fine. If I use the keyboard shortcut, I get a message saying the shortcut is reserved for grblHAL.

However, when open the shortcut menu, my two shortcuts are not asterisked. According to the shortcut list, HAL exclusive shortcuts are asterisked.

The two shortcuts are ctrl + 1 and ctrl + 3. The macros that they should run set Z to 3.175mm (1/8") and 9.525mm (3/8").

Double check your bindings - I think job pause for HAL default is CTRL-1 - I wonder if both the macro and the keybind are set to the same bind.


Disabling that or changing it might fix your issue. We’ll look at making sure new binds that have been set elsewhere are just unbound instead of duplicating the combo.

@KGN That was it, Kevin. I went in and disabled all the hal only shortcuts. Since I am not using hal, there is no point having them on.