Error 24 in gcode

Running Windows 10 21H2 64bit. gSender 1.0.3

File was created in VCarvePro 11. Post processor used was J_Tech_GRBL_Inch_NoZ_DynamicLaser_v1_6.pp.

Laser is Endurance 10 w.

The file runs until it stops with an error 24 on line 154524. Closing that and hitting resume, a second error 24 pops up on line 154529. After the second error, resume was not available.

I’m attaching an abridged version of the gcode file. (The entire file runs to ~885000 lines and is too big to attach.) There is nothing unusual in either of those two lines. They are just moves in X and Y.

2-laser.gcode (2.9 MB)

I’m also attaching the post processor file also. Change the .txt to .pp to use it in VCP.

J_Tech_GRBL_Inch_NoZ_DynamicLaser_v1_6.txt (4.6 KB)

Hi Grant. Is this the error ?
24 Invalid gcode ID:24 More than one g-code command that requires axis words found in block.

I don’t see any difference in the two lines you reference than the rest. Any hidden/special characters in them?

@paullarson I’m going to run it again to get the exact text of the error message. Clearly, I should have done that before posting. Duh!

I don’t see any difference in these lines, either. When I run it again, if it stops at the same lines, I’ll delete them and retype the visible characters, just in case there is some gremlin hiding in them.

I’ll report back tomorrow.

@paullarson I ran the same file just now. This time, the laser was not running. The router was not on and there was no dust collection or smoke extraction running. I just ran in air. Here is a clip of the error that I got

Here is a clip of the gcode for the line in question:

You can see that there is nothing weird about line 134716 or any of the lines around it, for that matter.

At that point, I clicked on “resume job”. The job started up again. Following that, it froze 5 times. After the 5th time, I just stopped the job.The puzzling part with all the freezes other than this error report was that there was no option to “resume job”

Here is a clip of the 5th freeze:

You can see that there is nothing amiss in the console read out. Notice, though, that there is no option to “resume job”. However, with each of the five freezes, I clicked on “pause job” and then the “resume job” button was visible and clicking hit resumed the job.

I believe that I will leave this to the experts now. That said, I am open to any suggestions that you have, Paul.

@gwilki , Grant, it looks like the error occurred in a different place in your gcode. I don’t think that there is anything wrong with your gcode. I did some poking around on the web and the best explanation I found was a communications problem between your PC/Laptop and the LM controller so that even though your gcode file is fine, by the time the gcode is received by the controller it has been corrupted causing the error.

@paullarson Tks, Paul.

Early on, I had all kinds of these problems and finally got them resolved through grounding my dust collection and moving to gSender from UGS. In this case, there are no grounding issues that i can see. I believe you are right about the failure to communicate. :grinning: This was just a for-fun project anyway to test out the idea of doing a project that was both router and laser work. The router file ran fine. I may try it again by splitting the laser file into smaller batches to see if that helps. It is interesting that the router file is 5Mb but the laser file is 16Mb. The laser is burning inside all the v carving so it is following the exact same lines as the router. Plus, there are no Z moves in the laser file. Strange.

Tks again for your help.

2 Likes

@gwilki I think I recall you mentioning this to me in the past and I’ve heard one or two other reports of gSender popping up errors on long jobs or just ‘randomly’. I’m not sure if the problem is in fact random or not but I’m wondering if you run again in 1.0.6 if you still see the same error in the same place or if you don’t see errors anymore or if the error happens in different places every time

1 Like

@chrismakesstuff Tks, Chris. My memory is good, but very short, so I didn’t remember the details of this thread. I just reread them and it’s all coming back to me as a vision now. :grinning:

Unfortunately, I cannot say if 1.0.6 has solved this problem, as I have taken other actions recently that, so far, seem to be addressing my many freeze issues. I’ve communicated those actions to you and I raised a support ticket a few weeks ago. So far, so good. The jury is still out, though, on whether I’ve finally put this to bed. If I have not, I’ll be back pestering you. :grinning:

I’ll close this thread, assuming that the issue is resolved.

2 Likes