Error message using ugs

hi all
i am getting this message:
an error was detected while sending ‘$J=g21g91x10f1000 (error 15) jog target exceeds machine travel. jog command has been ignored. streaming has been ignored.’
it tough being ignored…lol
no movement happens when i jog the axis.
the x,y, and z setting have been entered as per recommendations. I checked the usb cord; it’s fine.
any ideas how to correct it?
thanks in advance
Buba

Softlimits seem to be enabled. Write $20=0 into the commad window.

hi
thanks for the info. I’ll it a try

hi
changed $20=0. No improvement. Below are the codes. Also, the y motors sound like they are running. They are slightly warm to the touch. Checked all connections too. Thanks for the help. Crbl 1.1h [’$’ for help] LongMill build Feb 25, 2020

$$
$0 = 227 (Step pulse time, microseconds)
$1 = 46 (Step idle delay, milliseconds)
$2 = 34 (Step pulse invert, mask)
$3 = 0 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 225 (Status report options, mask)
$11 = 0.000 (Junction deviation, millimeters)
$12 = 0.000 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 0.000 (Homing locate feed rate, mm/min)
$25 = 0.000 (Homing search seek rate, mm/min)
$26 = 34 (Homing switch debounce delay, milliseconds)
$27 = 0.000 (Homing switch pull-off distance, millimeters)
$30 = 0 (Maximum spindle speed, RPM)
$31 = -2147483648 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 0.000 (X-axis travel resolution, step/mm)
$101 = 0.000 (Y-axis travel resolution, step/mm)
$102 = 0.000 (Z-axis travel resolution, step/mm)
$110 = 0.000 (X-axis maximum rate, mm/min)
$111 = 0.000 (Y-axis maximum rate, mm/min)
$112 = 0.000 (Z-axis maximum rate, mm/min)
$120 = 0.000 (X-axis acceleration, mm/sec^2)
$121 = 0.000 (Y-axis acceleration, mm/sec^2)
$122 = 0.000 (Z-axis acceleration, mm/sec^2)
$130 = -0.000 (X-axis maximum travel, millimeters)
$131 = -0.000 (Y-axis maximum travel, millimeters)
$132 = -0.000 (Z-axis maximum travel, millimeters)
ok

$G
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]
ok

$J=G21G91Y10F1000
ok

$J=G21G91Y10F1000
ok

$
[HLP:$$ $# $G $I $N $x=val $Nx=line $J=line $SLP $C $X $H ~ ! ? ctrl-x]

It looks to me like all of your GRBL firmware settings are messed up. If you download gSender from the Sienci website and install it, there is a function in gSender settings to restore the firmware settings to the Longboard controller. I believe in the Longmill documentation, there is also a list of the settings and what they should be.

1 Like

gSender Documentation

Check the Console section and the Firmware section for instructions in gSender.

Here is the link to a listing of the Firmware Setting: Eeprom Settings

And finally, here is the link to updating the firmware using the Arduino programming tools: gSender and Arduino Flashing tools

1 Like

Thanks Steven: I’ll give a go tomorrow morning.
Buba

2 Likes

Steve is right, these values are odd - spindlespeed a negative number and so on.
I also sugguest to reflash the Arduino, but want to throw in that you can also use the common Arduino IDE software or UGS for this purpose - or to just type in all the correct values proposed on the Sienci webpage.

3 Likes

Yahoo
Followed the instructions. She is working now!
Thanks for the reply.
Larry

2 Likes