File Loading issues 1.2.2

Oddly the changelog for 1.2.2 (the “current” version at this time) says that the file loading issue was fixed, but, all these months later, I just tried out gsender for the first time and it will not load any significant .gcode file [I made via Vectric Desktop] other than some templates that I had set up for flattening work pieces. This really doesn’t encourage one as to the usefulness of the tool, and it seems a shame for this version to be the first person a new user sees. I suppose I should try the “edge” version.

@CrookedWoodTex I appreciate the passion but if there’s a problem going on we’re happy to investigate…

@Brayvin I haven’t heard of the file loading bug continuing into 1.2.2 and seeing as we’re at the very Edge of releasing Edge to Main it would be a shame if after all our work on Edge the issue still has persisted. If you want to continue using UGS then I understand, if you still try Edge I’d be very keen to know if it resolves your file loading issue, and otherwise it’d be great to know your OS and sample file to try duplicating on our end. This could also be in the form of the ‘Diagnostics PDF’ within the ‘Calibrate’ tool

@chrismakesstuff I will be glad to work with you on this. I really like the native gamepad support, and was particularly impressed that the team thought up to add a quick function for flattening. I was out in my below-freezing garage last night for hours trying out gsender and getting it set up only to find the file loading problem (a show stopper since this means it won’t carve most of the small number of projects I’ve done since getting into CNC). Shall we use this thread or some other mechanism?

Just set up a new thread for 1.2.2 so it’s distinct from the 1.2.1 thread even though it may well be the same underlaying issue :+1: If you have any other info you can provide then it would greatly help us to know where we might need to look to replicate the issue. Information, g-code, screenshots, videos, any and all are useful :slightly_smiling_face:

Hi-it looks like I am having the same problem-I just updated to 1.2.2 and everything with the machine appears to be working but gsender will not load any file into the visualizer. Is there a fix that I just have not seen?

In my case, I am on Windows 10 Pro 22H2. What’s really weird is that I shut the PC down after I got frustrated. I came back two days later, booted back up, and have not been able to reproduce the situation. What happens if you “turn it off and back on again”?

I am using Windows 10 as well. Yes-I tried the reboot-same issue. Tried reverting back to previous version- same problem. I am starting to think something is up with my laptop now. I have another laptop with Windows 11-might try that next. One thing that I noticed was when I was updating to the 1.2.2 originally there was a pop up window that said something about a graphics card being out of date. I chose to ignore that at the time. In retrospect that might not have been the smartest thing to do, but now I don’t know how to get back to that update. Might also try to reload 1.2.2 again and see if it comes up again.

Just a follow up… I tried it again today and this time gsender would not even open. Chalking this one up to old operating software, because I tried my windows 11 computer in place of the one that would not load and I have no issues-running a job as I type this …on the old computer btw…reason why it didn’t work? I don’t know-all I know is my cnc is running again and that makes me happy!

1 Like