G-code words consist of a letter and a value. Letter was not found

Does somebody know exactly what this means and how I can even look at my g-code to see line 18.
I ran a simple text in Lightburn and burned it fine. However, when I try to burn a greyscale picture I keep getting this error code:
G-code words consist of a letter and a value. Letter was not found. But yet my text burned just fine albeit off my wood for some reason but it did fine.
It was running just fine the day before cause I ran lots of test cards. Now I cant even burn a picture on my Sienci laser.
My wife says burn another picture but I don’t know if its worth trying that.
Lightburn gives me this error. Gsender doesn’t. It just stops the laser.

@iwannaapple Open your gcode in a program like notepad++ and look at the offending line.

Then what? Ok I will. I’ll get back to you and let you know what it says.

The console complains about “on or near line 18”.
Not an expert of what I’m looking at but here is a portion if you could take a look?

; GRBL device profile, current position
; Bounds: X29.19 Y3.63 to X238.42 Y221.54
G00 G17 G40 G20 G54
G91
; GCode clustering enabled (max 8)
G4 P1
M4
; Image @ 118.1001 in/min, 100% power
M8
G0 X2.8313Y0.1429
; Layer Grayscale
G1 X0.0788F118.1S0
G1 X0.0545S1000
G1 X0.5023S0
G1 X0.3387S1000
G1 X0.7749S0
G1 X0.2038S1000
G1 X0.0788S0
G1 X4.4144Y0.0029S0
G1 X-0.0787S0
G1 X-0.0488S1000
G1 X-0.2641S0
G1 X-0.2181S1000
G1 X-1.1596S0:0:0:1000
G1 X-0.5396S0
G1 X-0.7864S1000
G1 X-0.0862S0
G1 X-1.8714S1000
G1 X-0.1521S0
G1 X-0.9787S1000
G1 X-0.2067S0:1000:1000
G1 X-0.0787S0
G1 X-0.0144Y0.0028S0
G1 X0.0787S0
G1 X5.2211S1000
G1 X0.2985S0
G1 X0.8266S1000
G1 X0.0787S0

@iwannaapple Without seeing the lightburn file, I can’t figure this code out. The laser power settings are either completely off - S0 - or on full power - S1000, which in a greyscale does not make sense to me. In my greyscale files, the power fluctuates depending on how dark the area of the image is. That said, I’m FAR from expert in gcode. Some others here may be able to explain.

Also, there are a couple of lines like this one
G1 X-1.1596S0:0:0:1000

I’m thinking these are the lines throwing the error, since the power setting is S0, so off, but then there are the additional settings :0:0:1000, with no letter before the values.

Clearly, I’m not competent to help with this. You may want to try the file again to see if there is a glitch in this particular file. Other than that, you could post to the Lightburn forum.

I am no gcode expert either but I copy pasted the gcode into a file and loaded it into CAMotics and it says the colons are invalid.

1 Like

What is this? This is not a grbl thing. Disable it and see if those colons go away.

1 Like

@NeilFerreri I’m glad that you saw this post, Neil. I figured you could teach us all something. My input was limited to “weird”.

1 Like

Quick search shows that Cluster Mode is to allow for faster engraving on boards that need it. It needs a different firmware, but it looks to be a thing on Smoothie boards (NOT Grbl, like the Sienci machines). They may have one for grblHAL, but that’s an entire rebuild of the firmware for more powerful MCUs.
I’d say just disable it in your settings in LightBurn (I’m not familiar with LightBurn).

I disabled it in Lightburn. Those descriptions they give don’t give the full story.

When I applied that setting I wasn’t aware that it wasn’t available for grbl.
Thanks for the info.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.