G sender alarm #4 and 5

Just got mt 30x30 up and running. Made one cut job , got ready to cut another today and the machine will not run probe right. It will set z alone fine, when i try to set xyz it touches z right then when goes to set z and y moves about 1/4 inch and crashes probe block, try to do x and y alone will move 1/4 inch and never touch block. Then sets Probe fail. Probe is not in the expected initial state before starting probe cycle when G38.2 and G38.3 is not triggered and G38.4 and G38.5 is triggered. This with a 1/4 down bit used one time, have set to factory specs with no luck other than scarring the probe block up real good, may have to get a new one. I have this loaded one two laptops, tried both with the same results. Running 1.0.2 on one and 1.0.5 on the other. Any help is greatly appreciated. Thanks Dan

@sst37chevy Welcome Dan! I am anxiously awaiting my MK2 so won’t be much help with your problem. I am positive that someone will chime in and help you with your problem. What I do ask is if you would post the solution here, so greenhorns like me can learn.

Again welcome!:blush:

Stay safe!

One more thing to add to this problem is that i got a notice of a update ,i did it and after this the machine runs very slow. The rapid speed is now slower than the precise speed used to be. I tried changing the speed rate with no luck, still very slow.

Still no response to help me out .How long does it take to get a response on average

@sst37chevy Hey Dan, have you reached out to the company? You may get quicker responses directly from them. Just my 2 cents worth anyhow.

Be safe!

When idle, Can you send a ? in the console and post the response?
Also, can you post your $$ Grbl settings?

@sst37chevy A belated welcome to the group,Dan. I’m sorry for being so late. I’ve deleted your duplicate post so that all responses will be in this thread.

In addition to what Neil has asked to see, can you post a screen cap of your touch plate settings. You get that by going to options, then probe.

Also, you mention that you set the controller to factory specs. Just to confirm the steps that you need to take to do that, in gSender, you need to go into firmware, then flash grbl. When the flashing is complete, you need to go back to that menu and click on restore defaults.


Thank you for the response, I wasn’t sure i posted this in the right place, that’s the reason for the double message, new to all this. I got Neil’s request but not sure how to go about doing what he has asked for, could you please explain it to me, don’t want to mess anything up. I can get around the computer pretty well but serious tech stuff I’m no good at. I did try ugs yesterday with the same results. I tried to run a test cut of a box and circle and both came out way too small for what i made them. I did download Mach 3 last night to see if problem is still there but haven’t got to that yet, i would rather use gsender as mach 3 looks to complicated for me. Thanks Dan

@sst37chevy Mach 3 will not run on our grbl machines.

As for what Neil asked for: in gSender, open the “console” window". In that window, type ? and hit enter. Take a screen shot of what the console window shows. Then, type $$ and hit enter. That will display a list of all your eeprom settings. Screencap that and post it here.

This is all to show people here how your controller is set up. It may help us to diagnose what is going on.

My problem is solved. I ran grbl update as you told me to do and the mill is running correct now. When I ran it before there was no instructions to go back and restore the defaults. don’t know how they changed but happened after I ran a update for g sender. only thing that upsets me is now my probe is now scared from the probe going wrong but not the end of the world, just glad to have it up and running again. Thank you very much for the help will be put in my book for the mill if happens again, Again thank you very much Dan

@sst37chevy Glad to hear it, Dan. I would not worry about a few scars on the plate. If they are really deep, simply touch down slightly away from the scars.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.