G Sender won't start?

Thanks for suggestions… Appreciate the ideas… Yes I have the latest version…64 bit… And Windows is 64 bit. When you say ‘clean up Windows’… Which method do you mean? I guess I can reset the entire machine with a fresh install but hoping to avoid that if we can figure out a solution. I’ve tried uninstalling…reinstalling several times… Looking in registry for any left over bits… Run as administrator…(local user is an admin anyway)… Also tried upgrading Windows… But it does fail to totally update for some reason. Very open to suggestions. Meanwhile Easel is running perfectly… But would like to get G sender to start and use it instead. Thanks!

Since you’ve already done the re-install step, another option you can try is removing the preferences file to see if some sort of corruption there is causing the program to not load.

Program settings are stored in your user directory under “C:\Users{USERNAME}\AppData\Roaming\gSender\gsender-0.5.6.json”. Try renaming this file something else (like “old_gsender-0.5.6.json”) and restart the application - a fresh config should be generated to rule out this step.

Another thing you can do is share the content of your program log which is in the “logs” directory in the same folder - any errors on program startup should be appearing there.

2 Likes

Wait longer for it to load? gSender has been known to take a “long” time to start up.

2 Likes

I installed the latest version and Gsender this morning and install progress indicator stayed stuck in the same place for a long time, until I remembered to open up Norton and disable its fire wall and auto protect features for 15 minutes. After I did that the install finished up. This could be why Gsender takes a long time to launch. I think as part of the launch process it phones home to check for an update which Norton blocks and eventually Gsender gives up and continues with the launch.

1 Like

Except that I don’t have Norton and previous versions will sometimes have a long delay and sometimes not. (I’m using 1.0.4 right now.)

Do you have another anti-virus/fire wall program? Could be doing the same thing. I’m not saying this is the only reason it’s slow to launch.

Thanks for the clues…I’ve gone in and renamed the .json file and this didn’t help unfortunately. I also tried uninstalling…then completely deleting this folder…reinstalling…GSender still just hangs and stays there for ages…so far around 10 minutes.

I also have no virus checker other than the standard Windows 10 virus checker and security,

I’ve gone to the Conents of log file. Looks like we have a syntax error and unexpected token…so hopefully that is a clue?

Was getting this also in the old log file pre me deleting it.

] [error] SyntaxError: Unexpected token in JSON at position 0
at JSON.parse ()

[2022-05-04 22:25:42.869] [error] SyntaxError: Unexpected token in JSON at position 0
at JSON.parse ()
at ConfigStore.reload (C:\Program Files\gSender\resources\app\server\index.js:355:30)
at ConfigStore.load (C:\Program Files\gSender\resources\app\server\index.js:317:12)
at Module.createServer (C:\Program Files\gSender\resources\app\server\index.js:13403:74)
at C:\Program Files\gSender\resources\app\server-cli.js:88:25
at new Promise ()
at _default (C:\Program Files\gSender\resources\app\server-cli.js:84:10)
at _callee4$ (C:\Program Files\gSender\resources\app\main.js:118:46)
at tryCatch (C:\Program Files\gSender\resources\app\node_modules\regenerator-runtime\runtime.js:63:40)
at Generator.invoke [as _invoke] (C:\Program Files\gSender\resources\app\node_modules\regenerator-runtime\runtime.js:294:22)
at Generator.next (C:\Program Files\gSender\resources\app\node_modules\regenerator-runtime\runtime.js:119:21)
at asyncGeneratorStep (C:\Program Files\gSender\resources\app\main.js:51:103)
at _next (C:\Program Files\gSender\resources\app\main.js:53:194)
at C:\Program Files\gSender\resources\app\main.js:53:364
at new Promise ()
at C:\Program Files\gSender\resources\app\main.js:53:97

Thanks! …I guess I can reset Windows 10…but prefer to figure out a solution given I’ve now got Easel working beautifully with my new CNC. (But want to use GSender)

Hi again…anyone got any clues about the above error? Thanks!

Alright I’ve made progress…if I sign into the PC with a different user…(the original user of the pc) then it works…I have checked the user with the problem is an administrator now too…but that doesn’t help.

so somewhere somehow there is a problem with the user profile I think. Anyway…thankfully I can get it to work with a different user account…would just love to know why mine doesn’t work! Thanks.

1 Like

I think I have a smiliar issue, but was unable to resolve it by creating a new user… Here is what I did so far:

I have tried two ways of running gsender on my Pi3 with Raspberry Pi OS 64bit. Both failed.

  1. Using the AppImage.
  • I downloaded the AppImage file using the build in Chromium browser
  • Moved the downloaded file to a dedicated Applications directory in my home directory
  • Right-clicked the icon to view the properties
  • Changed the execute properties under the Permissions tab from Nobody to Everyone
  • When I double click the icon the OS dialogue asks me if I am sure I want to run this executable.
  • When I open it, for a while nothing happens but then the splash screen is shown.
  • The splash screen never disappears anymore and in the task bar a task is shown named ‘Splashscreen.gif’
  1. Using the ARM64 deb package.
  • I downloaded the deb package.
  • Installed it using sudo dpkg -i gSender_1.0.7_arm64.deb
  • The gsender application appears under ‘Utilities’ in the app menu.
  • When I open it, for a while nothing happens but then the splash screen is shown.
  • The splash screen never disappears anymore and in the task bar a task is shown named ‘Splashscreen.gif’

Really hope I can get this to work so I can move my Macbook (on which gsender works fine) out of the dust room…

Should I use the 1.0.5 release until then?
At least, I do not see an armv7l.deb for 1.0.6…

In the meantime, I tried, but with no luck…

pi@3018:~ $ sudo dpkg -i ~/Downloads/gSender_1.0.5_armv7l.deb 
Selecting previously unselected package gsender:armhf.
(Reading database ... 92150 files and directories currently installed.)
Preparing to unpack .../gSender_1.0.5_armv7l.deb ...Unpacking gsender:armhf (1.0.5) ...
dpkg: dependency problems prevent configuration of gsender:armhf: 
gsender:armhf depends on libgtk-3-0. g
sender:armhf depends on libnotify4. 
gsender:armhf depends on libnss3. 
gsender:armhf depends on libxss1. 
gsender:armhf depends on libxtst6. 
gsender:armhf depends on libatspi2.0-0. 
gsender:armhf depends on libuuid1. 
gsender:armhf depends on libappindicator3-1. 
gsender:armhf depends on libsecret-1-0.

dpkg: error processing package gsender:armhf (--install): 
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Errors were encountered while processing: 
gsender:armhf

I think you’ll have to wait until @KGN gets back on here.

Just an update…I deleted the Windows user profile with the issue…and re added it… And then it started working again

So something somewhere became corrupt… But certainly related to the specific user profile.

Thanks!

as a test I downgraded from Bullseye to Buster.

Now it works. Version 1.0.5 that is.

I upgraded to latest 1.07 and problems came back… Software freezes on start…Win 64. I uninstalled and then went back to 1.05… Software starts again and works. So it seems 1.07 won’t start on some machines?

Can you share your program logs with me? Hoping to narrow down what was going wrong for some users with 1.0.7.

Logs are located in C:\Users{YOUR_USERNAME}\AppData\Roaming\gSender\logs\main.log

If you attach it hopefully it will help narrow down why this is happening to some users and not others.

Thanks,
Kevin

2 Likes

Perhaps its the same thing that causes an extreme lag at startup since Version 1.0.0 or so? No other software on my machine does that.

Thanks Kevin…appreciate the support…I’ll come back with the logs…as I’m back on 1.05…I think it may have deleted the old logs when I uninstalled…so went to bed!

this was some of the log error code the previous time:

] [error] SyntaxError: Unexpected token in JSON at position 0
at JSON.parse ()

[2022-05-04 22:25:42.869] [error] SyntaxError: Unexpected token in JSON at position 0
at JSON.parse ()

But will upgrade again Kevin and then see what I find to help troubleshoot it ater work. thanks again.

I also had an issue with Gsender not loading, I initially was using v1.04 and then updated to v1.05 thinking it was an issue that may have been fixed. It still was not loading, and then I read this forum and renamed the log file.

Now Gsender v1.05 loads but other issues have surfaced which did not exist before including:

  • During the homing cycle, the Z-axis will work correctly, but then all stepper motors will lock up and continue to be powered but not move. I have to disconnect and reconnect in order to reset them.
  • Gsender will show the position on all axis as -214748 (I have had to disable soft limits to be able manually jog).
  • After disabling soft limits, I am able to bypass the homing cycle, manually jog and reset the position on the axis.

I have tried running a program (without the spindle on) and there does not appear to any issues but I am not comfortable given the above items.