gSender 0.6.5 Released: Feedback thread

Notable things me and the team worked at this week:

  • New tool for surfacing
  • Moved most controllerEvent listeners to redux store to improve performance
  • Improved Job Time Estimation
  • Updates to Laser/Spindle widget to better track on/off state
  • New ‘About’ information
  • Fixed file units mismatch with preferred units

Things we’ve got our sights set on for the next release:

  • Still more improvements to performance by streamlining data parsing and manipulation to improve reliability and reduce possibility for data leaks (enabled worse hardware to run larger files more reliably and smoother operation of gSender as a whole)
  • Implementation of other ‘Setup’ tools such as motor calibration and machine alignment / squaring

Topics I’ve noticed feedback on that we’ll be looking to address soon:

  • Tool Changing
  • Bug when clicking a button on-screen followed by keyboard jogging
  • More exposed keyboard functions

Have anything else you’d like to see on the list? Now that gSender is in Public Beta I’m looking navigate feedback away from strictly the Google Form and will be trying out a Release thread for open discussion every time a new build is released. This should offer better, two-way conversations :slight_smile:

Happy Friday y’all!

3 Likes

@chrismakesstuff I hope it’s OK to point users to the link for this version. Here it is:

1 Like

Ah yeah, missed that haha. Thanks Grant!

1 Like

As a newb here trying to learn a new craft with my woodworking I want to say gSender is a breeze to work with. At least with my very limited knowledge, it is. I love how you have to verify the circuit with the touch plate before you can start the probe. Today was the first time I didn’t send the bit crashing into the plate.

At the bottom where it has your speed while you have a job running there is a " +, - ". Is that so you can increase/decrease the feedrate during the carving?

1 Like

@chrismakesstuff I’ve only done one small job with this version, Chris, but so far, it looks good. That said, it does still have the same issue as the last few releases. That is, when I click to load a file, it goes to some arbitrary folder. I cannot figure out why it goes to the folder that it does. I can only assume that, back in the alpha test, I really did run a file from that folder and now for some reason, it defaults to it. This is not a big thing, but it is a frustration. When I am running a job with multiple tool paths, clicking to load the second file, takes me to a folder that does not have any relationship to the job that I am running. Since this is a long-standing issue, I am assuming that it is not a simple fix.

1 Like

Yeah, spot on @Swinly :+1:

@gwilki you’ve hit the nail on the head with this one. Seems like a simple problem as first but there’s this whole security issue with handling folder navigation since gSender is fundamentally a web app wrapped into a desktop app. It’s one of the more highly mentioned features that we still haven’t found a fix to

1 Like

@chrismakesstuff Tks, Chris. One question, though. It is always going to the same folder, at least in my case. How was that folder chosen? Its location must be stored somewhere. If I knew where it was, I could change it to something more convenient than the current one.

Yeah, I was wondering about that. Perhaps not necessarily always navigating to the previous folder but if we could somehow allow you to set a folder that it always opens to. Not sure on that yet either though :bug:

The following g-code safe height does not execute in ver 0.6.5

G0 Z10; move to z-safe height
G0 F1000 X74.5043 Y77.9976

G0 Z0

The preview screen shows the safe move executing correctly
however the code does not execute on the longmill.

Furthermore the settings preset is ignored altogether.

@Andy1 If you don’t mind a question, Andy, what does the Mill do?

I ask only because I ran it just now on my Mill and it did precisely what I expected it to do. I set all axes to zero at an arbitrary location. I entered the Z10 statement and the Mill rose 10mm in Z. I entered the second line and the mill moved in X and Y. Then I entered the Z0 statement and the Mill dropped to the starting point in Z.

Absolutely, in console the commands perform as expected, however when loading and running a g-code file with that statement (move to a safe height) the sender ignores it.

The mill proceeds to the statements without altering the Z height.

Wow, @Andy1 thanks for pointing this out. gSender seems to be completely ignoring the line that has the semicolon-style comment on it. Will have to rectify that ASAP

While I have your attention, is there an explanation for having a preset safe height in the settings area, I have not seen this concept before…

The preset safe height is meant to apply to the goto buttons in the Location area, that way you’re not dragging or breaking bits along the way. It doesn’t apply anywhere else

Okie dokie,
In passing , I comment all my g-code statements , something I learnt along the way.
Thanks Chris & gwilki

2 Likes

Noticed yesterday when I would do a combo X/Y jog at the rapid rate of 50mm, it would only jog 5mm. I would then jog using just the X for 50mm and it worked fine. Also noticed when rapid jogging Z+ 10mm, sometimes it would only jog like 2.7mm or 1.5mm and it would screw up my Z zero. I was using both my laptop clicking button but also a mapped USB numpad. FYI. Mark

1 Like

After probing XYZ and Every time I change a bit, I start the probe to re zero the Z, after the verify circle goes green, it does not move. There is a slight hum but no movement. It doesn’t sound, feel or look like the motor is slipping. Every time this happens I stop it, cancel the alarm, restart the probe, verify the connection, and probe Z again. It works without a problem every second time.

Did I explain that alright ?

Hmm, @Swinly will be checking more into this on Monday. I heard from another user they were also seeing z-probe issues so there might be a bug floating around

1 Like

One more thing I forgot to mention but this might be user goofing around the mouse or keyboard. . I have had gsender pause “on it own” during a job and I would have to click resume. I’m not sure if it is me or not though.

1 Like

@chrismakesstuff - Chris, I just opened an issue on the gSender GitHub site. I don’t think it affects functionality but don’t know for sure. I posted the following comments and pictures there but thought I’d also post here as well.

"Just downloaded gSender v6.5 from GitHub and installed. Connected to LongMill controller no issues yet. Turned on Lightweight mode switch before loading a gcode file. When turned on gSender acted like I had loaded a gcode file. The load file icon does not show a file (X) loaded but the “Test Run” and “Start Job” icons appear. I selected both and they switch to the “Pause” and “Stop” icons with no movement of the tool and the visualizer is blank. I have previously loaded a file as it shows in the “Previous” window. Also every once in testing it was posting values in the X, Y and Z (not zero) positions even though no file loaded. See pictures below. Picture 1 connecting to controller. Picture 2 after connecting to controller and selecting “Lightweight Mode”.

1 Like