gSender 0.6.6 is now here!: Feedback thread

What’s new?

  • Sticky folders! Load files from the last place you navigated to
  • New tool change functionality - can now pause, ignore, or run code blocks on M6 commands
  • Added a prototype Calibration tool for axis alignment - step by step process to make sure your CNC is square
  • Alarm warnings now show an explanation of what the alarm code means
  • Faster splash screen
  • Spindle/Laser ‘active’ state changes are now updated more quickly in the UI along with other Laser widget improvements
  • Copy and paste text from the terminal
  • Tweaks to handling correct units display in overrides and surfacing
  • Refactored file information to Redux
  • Loads of small bug fixes pertaining to keyboard shortcuts, jogging, probing, comment processing, and the firmware tool
  • Minor styling changes

Things we’ve got our sights set on for the next release:

  • Still more improvements to performance by streamlining data parsing and manipulation to improve reliability and reduce possibility for data leaks (enabled worse hardware to run larger files more reliably and smoother operation of gSender as a whole)

Topics I’ve noticed feedback on that we’ll be looking to address soon:

  • More exposed keyboard functions
  • Headless Pi operation
  • Run outline prior to job operation
  • Joystick control

This was a super productive past two weeks for the gSender development team and we’re glad to be continuing to put out new features while making existing ones run even more reliably. If you’ve encountered any bugs or have feedback on this new release, let’s discuss!

Happy Friday :beers:


tried to use 6.6 the button to load gcode file would not work

1 Like

What operating system do you have it installed on?

I have it on Windows 10

Everything else work fine that was the only thing that would not work

Is it x32 or x64? We might not’ve checked File Loading on the x32 but at least on my end for x64 things are looking normal. Let me know

64 bit win 10 loads files for me.

1 Like

@chrismakesstuff Well, Chris, I’ve only run one project “in air” so far, but all looks good. My key mappings work again, the file load opens to the last folder that I was in, the birds are singing and all is right with the world. I’ll keep playing, but I think that I’ve pretty much run it through its paces.

1 Like

Ok @tjlang
recommendation to try

When you click on the Open file button, just leave it for 10 minutes and see if it comes up.

I decided to try what your reporting, and it took a easy 10 seconds for the dialog to popup.

I have 4 drives in my PC, and about 12 different network mounts to my NAS Drives and a few other local PC’s (on a Gen 10 i7 with 64gigs of ram)

so I was quite surprised to see take that long, but ya click on the open and dont touch anything for 5-10 minutes, just to see if its actually working, just slowly.

Chris its a 64 bit i will try again tomorrow

I just saw a similar comment on the FB group and he replied back saying he downloaded the new version manually and that fixed the problem for him. Perhaps it’s possible that the auto-updater gave you the x32 when you have an x64 machine and it’s effecting the file loading

Hi Updated to 0.6.6 32x manually. Everything works accept when I click to start job on the .nc files nothing happens. I can do a test run and the file works. And I loaded the surfacing code from in gsender and it works perfect.

Added the g code below in case that would help.
gSender - [Grbl]
Connected to COM3 with a baud rate of 115200
Grbl 1.1h [’$’ for help] LongMill build Feb 25, 2020
client> $$
$0=10 (Step pulse time, μs)
$1=100 (Step idle delay, ms)
$2=1 (Step pulse invert, mask)
$3=5 (Step direction invert, mask)
$4=1 (Invert step enable pin, boolean)
$5=0 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=1 (Status report options, mask)
$11=0.010 (Junction deviation, mm)
$12=0.002 (Arc tolerance, mm)
$13=0 (Report in inches, boolean)
$20=0 (Soft limits enable, boolean)
$21=0 (Hard limits enable, boolean)
$22=0 (Homing cycle enable, boolean)
$23=0 (Homing direction invert, mask)
$24=25.000 (Homing locate feed rate, mm/min)
$25=500.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, ms)
$27=1.000 (Homing switch pull-off distance, mm)
$30=3000 (Maximum spindle speed, rpm)
$31=0 (Minimum spindle speed, rpm)
$32=0 (Laser-mode enable, boolean)
$100=200.000 (X-axis travel resolution, step/mm)
$101=200.000 (Y-axis travel resolution, step/mm)
$102=200.000 (Z-axis travel resolution, step/mm)
$110=4000.000 (X-axis maximum rate, mm/min)
$111=4000.000 (Y-axis maximum rate, mm/min)
$112=3000.000 (Z-axis maximum rate, mm/min)
$120=750.000 (X-axis acceleration, mm/sec^2)
$121=750.000 (Y-axis acceleration, mm/sec^2)
$122=500.000 (Z-axis acceleration, mm/sec^2)
$130=812.000 (X-axis maximum travel, mm)
$131=812.000 (Y-axis maximum travel, mm)
$132=105.000 (Z-axis maximum travel, mm)
feeder> G10 L20 P1 X0 Y0 Z0
feeder> G91
feeder> G20
feeder> G0 Z0.25
feeder> G21
feeder> G90
feeder> G0 X0 Y0
feeder> G0 Z0
client> !
client> \x18
Grbl 1.1h [’$’ for help] LongMill build Feb 25, 2020

Hi @Grinner , you should be able to attach the file directly into the forum and I wouldn’t mind having a look to see why the file isn’t running for you. As well, is it just that file or are there other files that also aren’t running? (24.4 KB)

I have been using Carbide Create and saving as .nc files. Tried all old files. They all load I can run test in visualizer, but won’t cut. everything seems to work but when I press start nothing happens.

@Grinner @chrismakesstuff I just ran it on my test Uno and when I first hit run, I got an immediate Hold warning and the run stopped. Then, I clicked on pause job, then resume job. It ran successfully.

I looked at the gcode and removed lines 3-6 inclusive. Then the file ran. I’m not sure which of those lines offended gsender, but clearly one or more of them did.

1 Like

That worked @gwilki. I’ll use that method for now. I’ll try to do some trial and error to see which line it is specifically that is grieving me. Thanks

@Grinner I looked at the file and can conclusively say (though I can’t exactly comment on why it’s there) that the pausing is coming from an '‘M0’ command on line 5 of your file. When a sending software like gSender sees that command it will pause sending until it’s resumed by the user, you can see a full-fleshed explanation on the LinuxCNC site:

Perhaps there’s a reason why Carbide Create is putting this here but as of now I’m not sure

1 Like

Reloaded 6.6 right now everything seems to be working

1 Like


Thanks for the help, that is the problem. I would have got away with it too. If it wasn’t for that meddling update.

keep up the good work!

1 Like

@chrismakesstuff re:key mappings. Attached is a screen shot of my keymappings in 6.6. You can see that nothing is mapped to Z-. However, I do have the + sign on my keypad mapped to Z-, and it works. I temporarily changed it to the number 5 on the keypad and that mapping did show on the mapping page and it worked. When I changed it back to +, the mapping windows showed that it accepted the map, but the mappings page still showed Z- as being unmapped. It did work,though. This is a new issue in 6.6. It was fine in 6.5. Not a big deal, since the map works, but something to add to the list, perhaps.

1 Like