gSender 0.6.9 Feedback Thread: bug fixes and outlining

Wow, what a roll the development guys have been on. Another release after just one week bring along 0.6.9. Let’s take a look at the new changes: @all

What’s new / fixed?

  • New outline tool which will generate and run a rough outline of a loaded project file
  • Fixes for load file window not appearing in rare circumstances, jogging runaway in rare circumstances, and probe settings not being reflected in probe module until restart
  • Fixed issue with surfacing tool limits and ease of changing inputs

So the load file issue should now be resolved with this new update alongside some other bugs that were brought to our attention.

Moving forward, there likely won’t be the next release for 2-3 weeks since we’re going to be revisiting the core codebase of CNCjs (which gSender is built off of) and doing some really big overhauls. This is important because we’re finding that it’s still not running as reliably as we’d like it to, especially on older hardware and bigger files, and we know if we make these big changes later on then it’s more likely to have more bugs resurface as a result. Wish us luck guys because this is going to be a ride for me and the team and we’ll need all the luck we can get :pray:

Things we’ve still got coming down the pipeline:

  • Joystick control
  • Start from a specific gcode line to save projects gone wrong

And topics I’ve noticed feedback on that we’ll be looking to address soon:

  • Headless Pi operation
  • More guidance for first-time users
  • Manual value entry for X, Y, and Z locations

Getting more of these fixes out in a week is a big win where I’m very happy for our team but I’m starting to get antsy about getting gSender to version 1.0 - one where we can finally present a fully stable, fast, reliable, smoothly operable, feature-filled g-code sender to all LongMill users and CNC users as a whole. Once again, new documentation is still on it’s way to the gSender resources so watch out for that:

If you’ve encountered any bugs or have feedback on this new release, let’s discuss!

Happy Friday to you all and enjoy your weekend doing at least one thing that you love!


Wow that was fast. I just tested it for the issues I had reported. It looks like the probe and the console window issues have been fixed.

Good job guys!



1 Like

Just install 0.6.9 after using 0.6.7

Now I can’t open a file. I uninstall 0.6.9 and reinstall 0.6.7 and sane issue. 0.6.7 working good yesterday before the update

I try to drag gcode directly in gsender and it’s not working.

Laptop and windows are updated recently

@GuillC it looks like the visualizer isn’t loading at all for you, is that true?

Can I ask what version of gSender you’ve installed (x64 windows, x32 windows, etc.) and if you have any other information about the situation leading up to this?

Exactly I run Win7 x64. I didn’t retry something. But tonight I will try to install it on the laptop of my wife (win10 x64)

The outline feature needs 3 immediate fixes:

  1. Remind the user to set the Z for the router before starting! Ideally the user should set the Z=0.
  2. Allow the user to specify the height for the router to run the outline. They may need to avoid fixtures, clamps, etc.
  3. DO NOT lower the router after completing the outline.

Looking into this Frank, very concise list :+1:

The new outline tool once plunged in the upper right corner at the end. Fortunately or not (would it have broken my router or holder) I had the bit running in a high Zed position, so it only bored a hole where I didn’t expect one.

I’m running 6.9 for the first time and I’m having one problem that has happened a few times in a short period…

I was zeroing my xyz and it worked fine but I realized it was zeroing in on the shank of my straight bit instead of the bit itself. So I raised the z up to change to a better bit but it stopped after a couple of clicks. After that it would not move anywhere. I had to disconnect/reconnect to regain control of the movement. I noticed in the control panel it displayed the actions everytime I tried to jog the router but no movement. I don’t think it ever showed an error/invalid code. It has happened while jogging on the x and y too.

I thought I had a screen grab of the issue but it looks like I don’t, sorry

I’ve been having the same issue and just figured I personally was doing something wrong. Are you using Carbide Create? Just wondering if its something in the CC coding.

No I’m using carveco maker

If the user needs to manually stop the job gSender must show the last line# transmitted in the status area in the bottom left of the screen. Perhaps even also display the text of that last line. Without that it’s virtually impossible to locate a problem line.

1 Like

The issue happened again this morning. This always happens prior to starting a job. It doesn’t say locked, it always says “Idle” while it is happening. I was jogging the machine forward to set it up for a XYZ probe. When it got close to the probe plate I started moving it by doing a few quick clicks to get it into position. I think it was just two quick clicks on the Y moving in and it stopped responding. The control window was still showing the commands as I clicked on them but no movent. All cables are pluged in securely. Both in the connectors and the motors/control box.

I did notice that when it has happened, it was during a second attempt at a probing. One of the first times is when I used a wrong bit for the probe and when I corrected it is when the issue occured. Today I set my XYZ on a wrong piece of wood. When I replaced the wrong wood and started jogging back to retset the XYZ zero is when it stopped responding. Did that make sense? Below are a couple of screen grabs.

I’m running Win10 Home 64bit. Is there anything I need to do if this happens again? Something specific I need to make note of?

When it freezes up during jogging. Try clicking the test run button. But be ready, it may try to send the mill in the direction you were already clicking. So click test run then click stop asap.

It won’t keep going in the direction, just about as much as you had clicked for it to.

This has worked to fix my jogging issues everytime so far.


I will give that a shot next time I’m out there. thanks

I think I’m going to uninstall 6.9 and go back to an earlier version if that is possible. This issue happens multiple times every time I use it. Clicking test run did unfreeze it. Thanks @Kyle

1 Like

You can go back to an older version, but it will automatically update to 6.8

It was in 6.8 that they made it not automatically update… Or maybe 6.7, I think 6.8

1 Like

I just downloaded the latest version of gsender. carve worked great to about 90% then quit could not start it again it said it quit due to M0 no idea what that means tried it again from scratch same result … this happened also in the previous edition…before these two updates the program worked perfect any help would be welcome Wayne

The 0.6.9 gSender has been updated to deal with the M0 issues. Therefore you will need to go through your gcode file using notepad and delete all the M0 commands that Carbide Create puts in the program. It will perform properly after that. Remember to have fun everyday. :grinning:

1 Like