gSender 0.7.2 Shortcuts Jogging Issue and Profile Saving

With all the new shortcuts I have been redesigning my mini keypad layout. In the process of testing my new layout I tried the angular jogging (X-Y-, etc.) and am getting error 2. It works fine using the mouse on the screen but gets the error 2 using the keypad. Below is the console display results. First attempt is with mouse on screen and second attempt is with the mini keypad. Sorry to add another issue as I know y’all are trying to get it finished. It will get done I’m sure. Keep up the good work.

A second issue has also cropped up. Since I use a design computer and a CNC computer I tried exporting the settings. All went well until I tried to change the destination folder. The export wanted to use my downloads folder but I want to use my gSender folder. After I changed the destination and hit Save I get a file not found message. It won’t let me change the destination. Works fine to the downloads folder. Can this be fixed? I know I can cut and paste but to me that’s not the point. TIA

1 Like

Heyward, you know that we’re never bothered by being told what we’ve done wrong :grin:

I’m glad you’ve reported both of these. Should both be pretty straight forward. I want to make sure when we make the ‘stable 1.0’ version that there is it truly stable so people can feel confident using it. Any other bugs you find, send 'em my way!

1 Like

Chris, just installed 0.7.3 and neither of the items I posted has been fixed unfortunately. Angular jog with mini keypad still gives error 2 and export still only saves in downloads. Will not allow changing destination folder. Appears to create temporary file in downloads folder then after changing to a different folder can’t find temp file. Please try again. TIA

1 Like

@Heyward43 @chrismakesstuff Heyward: FWIW, I can export the gSender settings to any folder that I choose. It defaults to “downloads”, but I can select any folder. I’m running windows 10 if that matters at all.

Not sure why mine doesn’t work then Grant. I had explorer up with gSender and watched both when I tried to export. A temporary file was placed in the downloads folder when I hit export. Then I switch to my gSender folder and hit save and get file not found. Am I not doing something correct? I also use Win10 Pro/x64.

@Heyward43 I’ll send screen caps of what I see and do in a few minutes, H.

@Heyward43 OK, H, this is what I see and what I do.

With gSender settings open, I see this screen with the export settings button showing:

When I click on “export settings”, I get this page:

Note that the default location is “downloads” and the file name is something long with the date in it.

Note also the list of folders on the left, under newgrant(e). I scroll down that list until I get to where I want to go, in this case “gsender”, as shown here:

Note that now I am in my gsender folder. I click on the save button, which takes me back to the settings window. Opening the gsender folder shows that file is there, second from the right in the top row:

I hope that this helps.

Thanks for running through that Grant. Mine looks exactly like yours but I get this when I try to save:

Not sure what’s happening. I’m beginning to think it may be a Win10 setting but have no idea where to go. I even tried backing up library levels and shortening the name but neither helped.

@Heyward43 That’s a strange one, H. Looking at the popup, Windows is looking in f:\pictures. Your folder is in documents, not pictures. I don’t know why it would be looking in pictures, but that may be a starting point.

1 Like

@gwilki - that happened a number of years ago. A couple of our daughters and I were doing wedding photography and we usually took in the neighborhood of 2000-5000 pictures per wedding. These included engagement, bride/groom pre-wedding, wedding and reception. Double or triple that number with editing, album setup and space for multiple weddings. So I purchased a 1 terabyte hard drive to store and work with all of the pictures. So, in order to get the pictures folder (a system folder) onto the new drive I executed the procedure to move it. For some reason it also affected the documents folder. Never figured that one out. That’s why it shows under the pictures folder. Anyway I tried going straight to the documents folder, then system folder and still got the not found. I’ll do some more research to try and solve. Thanks for trying.