gSender 0.7.3 M6Txx Bug?

Weird issue I’m seeing that I think I’ve narrowed down to the handling of the M6 command.
If I send an M6T10 command in a file it throws an “unsupported command” error.
If the M6 is solo, no error.
If the T10 is commented out with a semicolon, no error.
If the M6 and T10 are not on the same line, no error.
For some reason the M6 is not captured by gSender when followed by the T-word. There seems to be some inconsistency, but I can’t replicate the issues when it allowed the M6Txx right now.

2 Likes

I’ve been talking to Neil over in the Carbide Community forum about this. I submitted a feedback form to the gSender team yesterday. (Including the gcode and Carbide Create file to generate the gcode ) I am not sure what is really happening either other than it seems related to M6 Tool Change and T tool number commands. It is inconsistent, sometimes it works but it usually fails if these commands are in the first gcode file used after loading gSender.

It seems my ID has been promoted so I can now upload files. Here are the files I have been having this issue with.

Lamp1_gSenderTest.nc (26.1 KB)
ModernDeskLamp_SBL.c2d (275.5 KB)

Thanks for noting this guys! Yes this should be a simple fix for how we’re looking out for M6 lines in gSender. We’ll try a fix for it by the next build this coming Friday :+1:

2 Likes

I’ll update that 0.7.5 should now be handling this issue. Would you guys be able to confirm working as expected on your end now?

I think Neil now has a couple of macros that now work. He would need to confirm. I have been playing with the “Code” option in 0.7.5. It’s better, but I still have one issue. If I put a “M0” pause command in the Tool Change “Before Change Code” area, the code in the “After Change Code” is not executed and the prompt for changing the tool does not come up. You only get a pause without a prompt. Hitting resume starts the loaded file’s g-code and not the “After Change Code” commands. If there is no pause command in the “Before” commands, everything seems to work.

With this setup, the “After” commands do not run. Remove the “M0” in the “Before” and they do.

1 Like

This should be fixed in the next release.

1 Like