GSender 0.7.4 new Probe Module

Hello,
Nice Looking Probe module modifications…
It seems we can still start the probe with the “Bit Size” set to “ZERO”
In the past, i have forgot to state the bit size, so there was an offset, should there be either a popup or a way to force the user to use a NON-ZERO “Bit size” (Aside from Z-Probe?)

2 Likes

Hello,
Now testing version 1.0.0
I now see that the DropDown Bit Selection list corresponds to the “Settings/Probe/Tools” list.
By Default, the list had .25in Endmill as first Item.
Wanting to understand the Behavior, i deleted the first Item (.25in) and the .125in tool was the “new” first item of the list.
After this Change, I see that the DropDown Bit Selection list is updated and the first (default?) selection is the .125in tool.
I then had to re-add the .25in tool to the list and saw that any new tool is put at the end.
I did not find a way to change the order (Drag&Drop/Arrows). I had to delete the tools and re-add them in my preferred order.
The “X” is not the only way to get a 0in (Zero) (i do not know why someone would use the Zero value when probing, ideas?)

1 Like

Hi Nicolas,

Reviewing your feedback on the probing module on my end I can’t find any way of having ‘0’ as a default bit size value however you can still manually type it within the probe module.

You’re correct though that we don’t currently have a way to rearrange bits, and while looking around I also found another quirk that the max current bit size that can be typed in is 9.525mm / 0.375in so I think we should probably increase that value

It’s been a while… i will try to reproduce… (if possible)
I tested today for a big 2minutes and was not able to reproduce…
Will look again…

Her is what I tried:

Uninstalled 1.0.2
I wiped my %Appdata% Gsender Folder.
Then…
Installed 0.7.1 and was able to reproduce
image
Uninstalled 0.7.1
Installed 0.7.4 and was able to reproduce
image
Uninstalled 0.7.4
Installed 0.7.5 and was able to reproduce
image
Uninstalled 0.7.5
Installed 1.0.0, and it looks good!

Could it be that Zero was shown/selected if no other bit selection was ever made with older versions?

Anyway, it seems solved now!

Thanks for a great App!

Awesomazing :smiley: thanks Nicolas